edited April 2017 in ORK Support
So creating this post for everyone to post any bugs he founds regardings ORK and the new update of Unity so we can help GIL fix them.

1) so my first problem is that now when i go into menus, the block control doesnt work (it doesnt disables the component on custom controls). - edit: this seems to be a bug with some changes on 2.10.1, trying to figure out what happened.

Navamesh agents also dont move all the time, seems problematic but i guess its normal due to the many navmesh updates of 5.6

3) Tooltip (info of items) and dragging doesnt work.

An other problem that might not be a 5.6 problem, but a general one. the change time scale, when you open/close a menu screen rapidly, sometimes the time scale change remains and you can't remove it.
Post edited by dlevel on
  • in case this is seen here first instead of the official bug thread:

    bugs with latest update (Unity 5.6.0f3)

    After the game starts, none of the UI appears, except for dialog boxes. the level transitions work when selecting a door but "interact" does not appear.

    when starting a dialog, the music that plays when the game starts begins to play.

    there may be multiple changes from Unity 5.5 to 5.6 that is affecting the coding, especially since NavMesh has been revamped.
  • It'll be some time before Untiy 5.6 is supported officially - the next ORK version will still be for Unity 5.5, before I start updating it to Unity 5.6.
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • ok thank you, is it ok if we update this thread for your help?
  • Sure, this will help once I update ORK to Unity 5.6 :)
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • edited December 2017
    Having some issue with my ui when i updated from unity 5.5of3 to 5.6of4 and ork 2.10 to 2.14.2. Am using unity new ui, when gui box is opened, and i click a button or closes after use, a big image of the gui box is displayed and never goes away. I looked at the hierachy window and i noticed that a bigger clone of the Gui boxes i closed, was created as a child object of UIpool. I really can't figure out why it happened. I also discovered another issue. The enemy combatant doesn't play the walk/run animation when using using unity nav mesh for hunting. They also pass under and push up the player combatant when they come close. Have tried increasing combatant box radius and disabling no combatant radius when setting up the move Ai . Any assistance will be appreciated
    Post edited by henkesky1 on
  • That's the pool of UI game objects that'll be reused by ORK's UI system - they actually shouldn't be visible in-game, due to not being part of a canvas.

    For the animations, try enabling Use Position Change in the combatant's movement settings.
    For the other issue, try using the Stop Range in the hunting settings of the move AI, or use a NavMesh Obstacle component on your combatants to make them obstacles for other agents.
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • check if you have a canvas yourself in the UI prefab
  • @gamingislove so how do i disable them or make them not to appear during runtime ?
  • @dlevel you mean all my ui shouldn't be parented to a canvas? But i never had that issue in the previous versions
  • no I mean use the example prefabs to make your own for the New UI, I had a similar problem like you when I had a UI prefab inside a canvas of my own by mistake
  • ORK creates its own canvas object where all the UI prefabs will be parented to. There shouldn't be a canvas on your prefabs you're using in ORK to create the UI.
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.