I've gotten to the bottom of this page http://makinom.com/tutorial/spaceshooter/02-player-move-controls/ and my ship doesn't move. I'm getting the error:

ArgumentException: Input Axis is not setup.
To change the input settings use: Edit -> Project Settings -> Input
Makinom.UnityInputManagerInputIDKeySetting.Tick (Makinom.InputIDKey inputKey, Int32 inputKeyID)
Makinom.InputIDKey.Tick (Int32 inputKeyID)
Makinom.InputKey.Tick ()
Makinom.InputKeysSettings.Tick ()
Makinom.MakiCore.FireTick ()
Makinom.MakinomHandler.Update ()

I've tried checking that I've spelled horizontal correctly everywhere. I've checked my input project settings which say the horizontal axis is controlled by the left and right keys. If I use my PlayerMover schematic in the supplied finished game it works correctly so the problem must be some where else?

Any help would be greatly appreciated.
  • You need to set up the input you're using in the Unity Input Manager. It's not described in the tutorial how to set them up, since this is basic Unity knowledge and the used keys should actually be already set up in the tutorial project (and a new Unity project).
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • Thanks for your reply. My project input settings look like this https://ibb.co/gNVMMH these settings work when I run the finished shooter tutorial scene, but not with mine.
  • Looks correct - make sure the input key setup in Makinom (Input Name) matches the name of the input in the Unity input manager.
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • That was it, I checked every setting over and over but somehow missed that, thanks!
Sign In or Register to comment.