I have recently upgraded my ORK version to the current version from 2.14.1. My Beastiary was working just fine.
Now, All the information is gone for an entry. Here was how it looked in 2.14.1 (still a work in progress)
beastiary

All of the information on the right page (except for the monster's portrait in the top right) is gone. It's just a blank page.

Anyone else, that has a beastiary, seeing this issue?
  • Hm, there hasn't been any bestiary changes since 2.14.1.

    Might be coming from some HUD updates, although the big HUD update was in 2.14.0 (element anchoring, etc.). Check the bestiary menu's HUD elements (or if you're using a HUD, the HUD's elements).
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • I'm not using a HUD to display the statuses. Under the Entry Box, I used the Add Status Element to create my entries. Here are a couple of screenshots that might help explain it better.


    Beastiary in action - only the portrait was added as you can see in the hierarchy.
    image

    Element page setting - only displaying the Status name and current value right now.
    image
  • What about the element bound settings of the HUD element?
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • I'm not sure what you mean. I'm not using a HUD to display the beastiary. I'm using the menu screen with a GUI Box and adding a status element on the entry box.

    Are we required to use a HUD now for the entry box?
  • No, but the HUD elements you add in the menu screen and those in a HUD are exactly the same, and their element bounds are found at the bottom of the element's settings - where you define the position, width and height of the element.
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • AH, now I see what you are talking about. I cleared out what I had and just placed 1 element for current status value combatant origin set to user
    My settings for the element is as follows:

    Position is 0,0
    Relative to Upper Left
    Width 100
    Height 100
  • Hm, yeah ... that should display something, and certainly does so in my test project.
    Think you can send me a small Unity test project where this happens?
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.