So, after doing a lot of work to get to the point where my characters attacks land and do damage and getting a lot of help in this thread ( http://forum.orkframework.com/discussion/4629/damage-dealer-not-working#latest ), which worked very nicely. I'm having a similar problem where my enemy combatants attacks don't seem to be doing damage. I've got basically everything set up the same way for them as for the players, but they've got an AI. All the AI does is fire off the basic attack repeatedly, but it doesn't seem to do anything when my player is in a place where they should get hurt by it.

I'm not sure where to check to resolve this, but any help would be wonderful!
  • edited May 4
    @Whatexists does your player has damage zone ork component on them ? select the player gameobject, then windows, ork scene wizard then damage one. What is the faction of the supposed Ai ? when spawning the Ai make sure the faction is set to enemy and that of the player is set to player.
    Post edited by henkesky1 on
  • Make sure the player has a damage zone and the enemy's attack uses a damage dealer (e.g. through an equipped and viewed weapon or directly on the enemy's combatant, or spawned by the battle event of the attack).
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • alright. I've double checked those things. Both the enemy combatant and the player combatant have damage zones on them. Their weapons have damage dealers (it's the same prefab for the weapon). And they are in different factions.
  • Are both using the same ability for their attack? If not, make sure the enemy ability's battle events activate the damage dealer.
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • They are using the same ability for their attack. They're also using the same prefabs. The enemy combatant is mostly just a copy of the player combatant with a few things like status changed around. Is that a potential source of the problem?
  • Hm, shouldn't really be an issue ... can you send me a small Unity test project where this happens to contact@orkframework.com?
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • Sure. It'll take me a little bit to put it together. If I don't send it today then I'll send it on monday.
  • That took longer than expected. Had problems with my server. But I've sent it to you now.
Sign In or Register to comment.