edited June 27 in Makinom Support
Gil, I need help on something. Im trying to make a cutscene where I am standing and I slowly rotate to look at a rock towards my right side, and moving towards that direction with the change position node local z axis.
Im doing it as first person, with the camera attach to a capsule.

In the past version, I can do it very easily with two rotate nodes next to each other.

Rotate to(rotate the capsule instantly towards the rock, as the direction, with x and z lock rotation enabled.)

Rotate to(rotate the child object of the capsule, which is the camera, with xyz all unblocked. Fade is set to slowly fade towards the rock. Wait enabled)

Change position node( since I already rotate the capsule instantly towards the rock, I just use the local z axis as the direction.)

This worked very well. But then I updated to the latest version and everything stop working. By doing the above, now the capsule still rotate to look at the rock, but the camera fading is not accurate at all. Its not rotating to look exactly at the rock. If I delete the capsule rotate to node and just simply rotate the camera, it'll rotate correctly. Its only when I rotate both that its not working.

Since its working in past versions, is this a bug? If not then, do you know of a way to do it? I tried a lot of things, but I still can't do it.
Post edited by Shadow_Fire on
  • Hm, there hasn't been any change to this in the last update.
    Could you send me your event asset to contact@orkframework.com?
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Hm, I don't know if this is how it's supposed to look like, but in my test it behaved as the schematic is set up:
    - sets the player capsule to look at the rock
    - fades the camera to look at the rock > basically just fading the vertical rotation, as the camera already looked at the rock horizontally through setting the player's rotation (parent of the camera)
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited June 29
    I'll show a video example of what I want. :)
    I'll post two videos. Both use the rotate to nodes as describe above.
    Rotate to (player rotate instantly)
    Rotate to (Camera fade, wait enabled)


    The first video is from version 1.9.2, my last version before I updated to the latest. The rotation works as intended. The schematic will start after I go up to the wall and click on the paper. When the player rotate instantly to the cube, it did not bring the camera along. Instead, the camera slowly fades towards the cube. After finishing fading, I paused the game and checked the rotations. They both point exactly at the cube.
    Video of first clip :



    The second one is the latest version. Notice how when the player rotate instantly to the cube, it brought the camera along with it. After the player finished pointing to the cube will then the camera started rotating. At this point, the camera will just rotate to the right, missing the cube altogether.
    Video of second clip:


    Regarding the first clip, it works for every previous versions of makinom. It's only the latest version one that it stops working.
    Post edited by Shadow_Fire on
  • Actually, both clips look wrong based on the schematic you sent me.
    Setting the rotation of the player will also change the rotation of the camera, since it's a child object of the player. That part of the 2nd video is correct, although the following rotation is wrong (but working on my end).

    I guess I'll need a small Unity test project with your player/camera setup to check this out.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited June 29
    Weird, weird. Alrighty, I've sent it. :)
    Post edited by Shadow_Fire on
  • edited June 29
    Checked it out - try using Local Space when rotating the camera, since it's parented to the player, changing the global rotation will result in unexpected results.

    However, in your FPS setup, you'd generally want to do this differently, due to horizontal rotation being applied to the player instead of the camera. Otherwise you'd have the camera and forward movement of the player completely off afterwards.
    I.e. the player should only rotate on the Y axis (blocking X and Z), the camera should only rotate on the X axis (blocking Y and Z) and in local space. You'd only rotate the camera on Z axis if you want to tilt it, e.g. leaning left or right :)

    Also, due to the FPS control schematic not being blocked (e.g. through a block control game state), that might interfere with rotations.
    Post edited by gamingislove on
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited June 30
    Ahh that makes sense! I guess I was confused because in the past versions when it worked with the method I used above, I was confused back then too. I always thought instant fading the player to look at an object would also make the camera move, since it was the child object of the player, but it didn't. It didn't make sense to me, as I didn't see how it could work. After thinking for a bit, I just thought you implemented makinom to be that way.
    What you said makes sense now, finally. So I just also fade the player slowly towards the rock while fading the camera at the same time, on the x axis. Works well.

    Oh yeah Gil , I think the rotate to node fade is buggy. Long ago you already fixed it, but I think it came back. For example, try this - Trigger a cube to look at another cube up in the sky. With all lock rotations disabled, if you instant rotate the ground cube, the local z axis will point exactly at the air cube. But if you fade the cube slowly, the ground cube will fade to point elsewhere instead.
    Post edited by Shadow_Fire on
  • Will check that out.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Gil, the makinom rotate to node was fixed, but I think the Ork's rotate to node is broken :)

    Same setup as above.
    One cube on the ground, another high up.
    The auto event is on the ground cube. In the event, I have a rotate to node, which rotates the ground cube towards the air one. The ignore X Y Z are disabled. If I disabled the fade rotation, it will rotate to point exactly at the air cube. If I enable fade rotation, it will rotate towards the air cube, but it won't point exactly at it, just towards the general direction. It looks like it is ignoring the Y rotation.
  • Yeah ... the Rotate To node in ORK is only rotating the game object on the Y axis, i.e. it turns the game object toward the target. Changing this would potentially break a lot of projects out there, so that's how it is :)
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited August 29
    I see, fair fair :)
    I could have sworn it used to rotate like I said though :D
    I must have been dreaming hahh.
    So that means if I want to have a gameObject in the scene to slowly rotate to face another game object exactly, I will have to use makinom, right? I tried it in Makinom, and it works well, so if I have to, no complain from me.

    Edit: Ahh so I guess trying to rotate the player and camera as you said above will not work in Ork too.
    However, in your FPS setup, you'd generally want to do this differently, due to horizontal rotation being applied to the player instead of the camera. Otherwise you'd have the camera and forward movement of the player completely off afterwards.
    I.e. the player should only rotate on the Y axis (blocking X and Z), the camera should only rotate on the X axis (blocking Y and Z) and in local space. You'd only rotate the camera on Z axis if you want to tilt it, e.g. leaning left or right :)
    Makinom, here I come.
    Post edited by Shadow_Fire on
Sign In or Register to comment.