I decided to jump into Makinom with the 2D Roguelike tutorial, since it covers most of the basics that I will need to know for the game I want to make.

However, I have run into a couple issues.

First, I wasn't able to load the project as the Tutorial says. I was able to import all the assets, but the downloadable didn't come with a project that could be opened. I believe this is the source of my later issues, since I think there must be some key settings that I am missing.

At first, when I got to the point in the tutorial where you should be able to play it and move a single space, I couldn't see the player. I had to fiddle around with the layers first (no BlockingLayer, I believe was the issue).

Now, I am to the point where you can walk around, bust walls, gather food and go to the exit. However, my player does not collect the food and nothing happens when he touches the exit.
Also, when I break walls, no animation plays. I don't know if an animation is supposed to happen or not, but on the generic Unity version of this tutorial, the character plays an animation whenever you bust a wall.

Can anybody help me figure out what Player settings need changing (if that is indeed the issue?) I have double and triple-checked the Schematics and all the Machines, they are setup exactly as described, but I cannot progress to the "Enemies" section of the tutorial until I correct what went wrong.

  • edited September 2018
    Unzipping the downloaded file should leave you with the folder containing the project - you just need to open that with the Unity editor. If that doesn't result in a single folder (or something that's not a Unity project folder), try a different program to unzip it (e.g. WinRar or 7zip).

    The issues you're having are most likely coming from that initial issue, as just importing the assets will probably break a lot of stuff in the project :)
    Post edited by gamingislove on
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Yeah, I'm stupid.

    Click Open. Click on file. Press "Select Folder". Bam, it loads everything.

    My trouble was that I created a new project and was trying to open the tutorial from inside the new project...somehow.
  • Okay, so I went back through the tutorial all over again, only this time in a new project as intended. (However, I didn't re-make the schematics manually, I just opened the "Finished" versions, then saved new copies).

    However, I am running into the same exact problem with the tutorial as I did before. The player sprite loads correctly this time, and has an idle animation (slight bounce), but he doesn't animate when breaking walls (I don't know if he is supposed to, though).
    But more importantly, I cannot collect food/soda, and the exit does not take me to the next level.
    So I am guessing there must have been an update to Makinom since the tutorial was made, and there is now some kind of extra setting that has a default which is screwing up the process.

    I think the tutorial needs to be corrected.
  • Hm, there haven't been any changes in that regard. Just tested the project and it worked fine ...
    Hitting on walls should play an axe-swing animation.

    Which Unity version are you using?
    When testing, pause the game and check the different objects (e.g. soda/food or the exit) - they should have a box collider 2D and a trigger machine attached.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I am using Unity 2018.2.0f2 (64 bit)

    Each clone has box collider 2D and a trigger machine.

    Ugh. This is a headache. I don't know enough to know what's wrong. :(
  • edited September 2018
    I'll check it out, I don't think I've tried it with Unity 2018.2 yet :)

    Edit: Still working fine here ...
    The project is for Unity 2017.1, but upgrading it still worked fine and playing didn't cause any issues. Try importing Makinom from the Asset Store using Unity 2018 to get the correct Makinom version, although it still works with the 2017 version of Makinom.
    Have you tried downloading the tutorial project again? Maybe yours is somehow corrupted.
    Post edited by gamingislove on
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I gave up trying to get it to work.
    I need to know more about doing super basic things in Unity.
    Like setting up a scene, adding the right sort of layers, adding the player object and the sort of basic settings you need it to function in a 2D game? Something about rigidbodies?

    I don't even know. Following tutorials from pre-made asset packages doesn't show how to make a sprite animate, it just shows how to use Makinom to activate a pre-designed mecanim. It's as if I need to learn how to program something completely in Unity, before I can even grasp how Makinom works. That makes makinom kinda pointless, if the idea was to make a game without learning all the code.

    Maybe there is already such a tutorial, but I can't find it.
  • Yeah ... you'll need basic Unity knowledge for all Makinom tutorials, since they're teaching Makinom, not Unity :)

    There are a lot of very good tutorials available at Unity's website, I'd highly recommend to go through all of them to learn your way around the engine's features and workflow.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.