edited September 26 in ORK Support
Gil, do you know why my base attack is trying to activate twice at the same time?
I'm using mecanim, and the any state is transition to "Kick". The kick is my base attack animation. (mecanim setup is just like in your tutorial).
When I press the control map key, my character will try to kick, but then as it is about to lift it's leg, it will instantly reset the animation to kick again. In the kick ability battle event, I just use a play combatant animation node, with wait enabled. I tried changing the delay and reuse option in the kick ability, but still didn't work. I noticed that in my animator, when I press the control map key to kick, the blue line will go from any state -> kick twice.

Also, have you seen my email to you about a third person controller I am interested in commissioning you in the future? :)
Post edited by Shadow_Fire on
  • Mecanim animations only have wait times if you've defined them in ORK's animation setup. So just enabling wait in the node will not actually wait until the animation is done.

    I'd love to make this as easy as using legacy animations, but there's still no reliable way to get the duration of an animation in mecanim ...
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited September 30
    Ahh, I see. So in my battle event, all I need to do is just put Play Mecanim Animation --> Wait(1sec), right?
    I use to not like mecanim at all, but ever since I discovered the retarget animation setting and other things, whoa, it makes life so much easier now. That's why I decided to just stay with mecanim.

    Gil, there's a problem I seem to can't solve at all. I am playing my base attack with the player controller being blocked.
    Using mecanim, with the default ork controller, whenever I run and try to click the base attack control map key, I will stop in place, but the attack animation won't play at all, only the idle one, even though a notification pops out saying I have performed an attack.
    I checked the animator, and it seems like the attack state does play, but it just play so fast and then skip right into idle state.

    When I am playing my base attack while not moving, it works well. Also, if I disable block controller, and perform an attack while running, the attack will play too. You know why this is happening?

    Edit: After doing some tests, it seems to be the Use Auto Animation of the character. In my kick ability battle event, at the beginning if I disable use auto animation and enable it back at the end, everything works fine again. Weird weird.

    Man, mecanim is so much headaches :D
    I emailed you again about the mecanim makinom controller. Do you have a price for me? :) If you do, and if it is close to what I have save so far, I will just commission you right there and then to make me one. Will save me a lot of time, and I can focus on other things. Looking forward to your reply!
    Post edited by Shadow_Fire on
  • edited October 2
    An alternative would be to add a small Wait node (e.g. 0.1 seconds) before playing the animation to give the system time to play/change animations :)
    Since mecanim is somewhat hard to control, directly playing attack animation might be overruled by the auto animations (or prevented due to being in transition ...) - that's why I recommend using the legacy system unless you absolutely need some mecanim functionality.

    I'll get back to you regarding the email soon :)
    Post edited by gamingislove on
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited October 3
    I'll try the above!
    In this case, I really need mecanim :)
    For some of my attacks, I have to enable root motion for them to look pretty. I love the masking of some body parts too. Make for some unique animations.

    Alright, I'll look forward to email :)
    Post edited by Shadow_Fire on
  • edited October 2
    regarding the automatic animations interupting the macanim animation, is there any way to prevent that in the event system? like if stop Move AI or something? I m having a hard time adjusting this, and it's kinda mandatory to use mecanim on my project
    Post edited by dlevel on
  • @dlevel
    Yes, there's the Auto Animation node to turn this on or off per combatant :)
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • awesome, also I see that having a new layer in mecanim with additive works pretty good for attacks
Sign In or Register to comment.