edited September 26 in ORK Support
Hi everybody,
I'm in the middle of upgrading Unity to 2018.9 and ORK. I upgraded to ORK 2.17.1 (from 2.14 I think) yesterday and everything was working fine, but when I upgraded Unity to 2018.2.9 (from 2017.1) this error appeared when using the Emit Particle node:
MissingMethodException: Method not found: 'UnityEngine.ParticleEmitter.set_emit'.
ORKFramework.Events.Steps.EmitParticlesStep.Continue (ORKFramework.Events.BaseEvent baseEvent)
ORKFramework.Events.Steps.EmitParticlesStep.Execute (ORKFramework.Events.BaseEvent baseEvent)
ORKFramework.Events.BattleEvent.ExecuteNextStep ()
ORKFramework.Events.BaseEvent.StepFinished (Int32 next)
ORKFramework.Events.Steps.CalculateStep.Execute (ORKFramework.Events.BaseEvent baseEvent)
ORKFramework.Events.BattleEvent.ExecuteNextStep ()
ORKFramework.Events.BaseEvent.StepFinished (Int32 next)
ORKFramework.Events.BaseEvent.Tick (Single delta)
ORKFramework.BaseAction.Tick ()
ORKFramework.BattleActionHandler.Tick ()
ORKFramework.Battle.Tick ()
ORKFramework.ORKCore.FireTick ()
ORKFramework.ORKHandler.Update ()
image

I tried deleting the DLLs and reimporting them but this didn't solve the problem.

I looked this up in the bug report thread, but it seems to have been solved by upgrading ORK to 2.16 in that case, which I already did. Sorry if I'm missing something and thanks for your help!

Also, is Unity 2018.1 (which is explicitly mentioned in the changelog) the last officially supported version of Unity? Or is Unity 2018.2 supported as well?
Post edited by azazello on
  • Make sure to download the update in Unity 2018 to get the correct version. If you can't download it again (having it already downloaded in Unity 2017), you have to delete the asset somewhere in your Unity installation (I think) to be able to download it again.

    Unity 2018.2 is also supported :)
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • That worked! For future reference, the way to do this seems to be to remove the desired asset from ~/Library/Unity/Asset Store/ (on a OSX) or C:\Users\accountName\AppData\Roaming\Unity\Asset Store (supposedly, on Windows). Re-downloading and re-importing ORK did the trick.

    I'm marking this as solved, thank you very much!
Sign In or Register to comment.