Hi guys,

Is there an option somewhere that prevents using multiple abilities on a weapon?

Just asking because I have two different abilities, when adding them both to the weapon only the first (Equipment ability 0) ability works in game. The second doesn't.

But if I remove the first ability then run the game the remaining second ability works.

They just both don't work together, which is what I want. Just wondering if I've set something somewhere.

For testing, I just use some status effects and have the abilities toggle them so I can see them working in the editor of the combatant.

The abilities themselves don't have any requirements or anything, they just toggle these 2 status effects with different names but nothing else special about them.
  • Hmm, alright trying it a different way.

    Using the same abilities and status effects. If I can't use both abilities at the same time on the weapon, then I'll remove the abilities from the weapon and use an equip event to give both abilities to the combatant via the add temp ability step.

    Works. Both abilities can now be used at the same time.

    Seems that when added to the weapon, only the first ability gets recognized?

    Solution: use an equip event to give required abilities to player instead of adding them to the weapon directly (which would be prefered/less hassle/easier to read). Then use an unequip event to remove the abilities.

    Also noticed the ability use cost audio clip doesn't get played (use sound type disabled), is there extra steps in setting up the character to get this sound to play? I noticed the combatant has two audio sources added...
  • edited January 17
    Seems to be a bug, will be fixed in the next update.

    As for the use cost audio - that uses the same functionality as the damage audio settings, so it definitely works. It'll be played on the user, if the game object doesn't have an audio source (either on the root or any child object) it'll add one. Could be that the audio listener is too far away to hear it?
    Post edited by gamingislove on
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • In regards to the abilities, I also notice that in the editor under Equipment ability 0 there is only the "Remove" button, it seems that usually you have remove, copy and move up/down. Not sure if the bug prevents them from showing or not.

    As for the sound, under the Use Cost > Audio clip. I can't hear it. At first I did think maybe the listener is too far away so I checked it, still couldn't hear it. The Consume items works, so the use cost does work I just can't hear the sound.

    But I made the battle event (following the fireball tutorial) and using the play sound step with actor>user and audio clip 0. It works. Works perfectly. I can hear it. Just can't hear it when I select it for the use cost. From what I read in the fireball tutorial, this should be playing the sound on the user which is what the use cost should be doing?

    I'm using 2.17.1 if that helps. I went to upgrade but its deprecated, from what I read in the other post of yours, unity should re-link the new version to what I have so I should be able to upgrade to the latest soon or do I need to re-purchase ork because its been over a year?
  • edited January 19
    On another note, under the move AIs there's "Move component settings", if you select default and then enabled "Add Component" your character should have the ORKFramework.Behaviours.MoveAIComponent added at runtime yes?

    I've disabled this and am now using the navmesh agent option but the moveaicomponent is still being added.

    Also, for custom, I can set my com.Mystuff.Classname and any of the methods I put in for the position, speed and stop don't seem to get called.

    I made for example, public void SetPosition(vector 3 blah) and put a Debug.Log("test") inside and it never gets called..?
    Post edited by braddon85 on
  • edited January 20
    Ah I get why the navmesh option still uses the moveaicomponent, it still needs it because otherwise the navmesh won't reach its target and it will just sit there unless the moveaicomponent tells it "you've waited in one spot too long, time to go somewhere else".

    Still get's added even though the "Add Component" option is disabled.
    Post edited by braddon85 on
  • edited January 21
    Will add copy/move buttons to the equipment abilities in the next update.

    Tested use cost audio and it worked fine on my end. Does your combatant's prefab already have an audio source attached? My best guess is that the audio source is set up in a way that prevents the clip from being heard. The Play Sound node (depending on its setup) might play it differently, e.g. using Play One Shot.

    The move AI's component is added in any case, as this is the component that handles the whole move AI (e.g. finding targets). The move component settings define which component is used to actually move the game object. The move AI component doesn't move the game object, it lets the move component know where to move to.
    I.e. the Add Component option defines if ORK adds the move component (e.g. a NavMesh agent component) to the combatant's game object.

    Try defining your custom component's class name without the namespace - also, do you get any error/warning in the console when using your custom component?
    Post edited by gamingislove on
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.