Here's the thing, I will try to explain it as clear as I can.
I have an enemyMovement tick schematic. In in, I have a navmesh destination that will make the enemy go to the player. I also have a check distance, so that when the enemy is close to the player, it will stopped the navmesh, and will just the change position node to rush the enemy to the player, and another change position node to move the enemy back, out of the player range.
Also, on the enemy I have a enemyLosesHp trigger schematic, which is trigger upon entering the sword's trigger on the player's hand. In the enemyLosesHp trigger, I just have two nodes, the change scale node and the change position node, to move the enemy a bit back.
The problem is that when the enemy is moved back, the enemyMovement tick schematic just stopped working. It's weird. It should not be like that, and nothing is disabled. I even have a show dialogue in the tick schematic that will show a small dialogue every frame, to make sure the schematic works. The dialogue disappear after the enemy is pushed back.
I will also include a link to the dropbox and will sent it to you via email, in case you want to check it out, and it's much faster than to try to recreate it. The file unity version is 2018.3.0f2.
  • I'll check it out.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Alright, found the issue that's causing it. Moving a game object over time in multiple schematics (at the same time) can lead to this issue, getting the schematic stuck.
    Will be fixed in the next update.

    Meanwhile you could change your setup, having the enemyLosesHP schematic just setting a flag (e.g. a bool object variable) and handle the movement in the enemyMovement schematic.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Awesome! Thanks for the fix :)
    Thanks for the tip too. Will make it more clean.
  • To elaborate on the fix, this'll still not allow you to use multiple move over time at the same time, as the latest move will cancel out the previous - but the fix will at least notify the schematic that the move finished and allow it to continue :)
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Of course, that makes sense! Thanks for the hard work :)
  • Gil, the Makinom one is fixed, but the Ork one is having this issue :)
  • Will be fixed in the next update :)
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.