edited March 22 in ORK Support
Hello.

I'm pretty new to the technical aspect of this program so I apologies in advance if this is a dumb question.

I noticed that when one of the default models is under the effect of Move AI + SimpleMove.cs, the models will play the walking animation automatically when they start moving.
I'm not sure if it's through the Legacy system or not, but I can't get it to work with my Mecanim animated models.

I just wanna ask it's possible to automatically animate Mecanim models in a similar manner whether it be through a feature I've overlooked or through scripting.

Thanks in advance!
Post edited by PottedCactus on
  • That's due to the combatant's Auto Animation setup - if your combatant uses Mecanim animations, you need to set them up accordingly. Here's an example Mecanim setup.

    If you haven't done yet, I'd highly recommend going through the game tutorial series before starting adding your own stuff. They're there to teach you all the basics and workflow of ORK :)
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Okay I looked over the Mecanim setup, and as it turns out, I overlooked a very important part of the progress and I've fixed the issue.
    The only problem now is the occasional slow startup and jittery animations, which I'm assuming is a threshold issue, I'll have to tinker around with the settings later and report back to you if it works.

    Thank you very much for your patience and helpfulness! Couldn't get this project done without you.
Sign In or Register to comment.