edited June 10 in Makinom Support
Game Starter from Makinom has one simple Schematic where it loads 'MainMenu' scene where ORK Game starter is.

Today I opened my project to find out it no longer is able to load a simple scene, hangs in black with '_SceneChanger' in Hierarchy popping out with yellow triangle message:
https://imgur.com/a/YsmCA5B

It's just a game starter that I've added and one node for Load Scene.

I don't use any scene changers in my game, that appears to be bound within Game Starter object. That object has no colliders, nor the event with the Load Scene node.
https://imgur.com/a/cRkoTyV

So I went out and skipped that scene directly to ORK Game Starter who calls Main Menu. The Menu called but when pressed New Game, it also hanged with black screen on _NewGameSceneChanger, though there were no warnings...Yesterday I closed the project when I played everything and it worked. Today it decided to went full retard on me.

New Events with Load Scenes doesn't help. I simply can't load any scene in my project anymore.
Post edited by Machal on
  • I found out, that when I remove t he 'Fade In' 'Fade Out' features in 'Load Scene' node it will load the scenes, assume it skips the scene changer.

    But my Interaction Machine components stopped playing animations and Collider Machines don't work. I guess it's time to re-roll my old backups as this looks like some files got corrupted for some reason...
  • Sounds like your Unity project has a timescale of 0. Check that in Edit > Project Settings > Time in the Unity menu, Time Scale should be set to 1.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Dear god, thanks! That was the issue. My game uses time and looks like I turned project off in paused time. Christ, how did you know, I would never guess this :D
Sign In or Register to comment.