I have 2 issues I have been unable to find a fix or work around for.

1. When I enable Steal, the character runs to the enemy model, then sinks about 1.5 Y down into the ground, hits, then raises back the same 1.5 Y Up to be back on the surface and runs back to his base. This only happens on 4 legged creatures (A Giant Rat) as the Tentacle in the same fight doesn't make this happen.
I have checked character Controllers, added Box Collider to the model, made sure that the On Ground is set to Character Controller, I have raised the controller, lowered it, increased it's radius, nothing makes a difference. I am thinking there is something in the coding for when you enable Steal on an ability, it makes the character using it sink abouy 1.5 Y on animation. As if it needs to be lower on the model to steal from it and thus puts my hero into the ground to do so.

2. The Level Up Dialogue refuses to play. No matter how I change my settings for Active Time and End Battles, Battle Texts, etc, Use a hub with attribute settings didn't work. Changing the Loot Dialogue to 2 separates that follow each other only shows battle gains, not level up. I have it checked to show notification, show console.. Tried one or the other only. I was only able to make Flying Texts show at the Victory screen in Green. "Mel has gained Level 2" using the callers like %n and %, but that is all I can get working.

What is odd, this all worked before on an earlier project. This only happened after the last Ork update, and updating Unity to the newest version. I can copy the same settings, and same scripts for attack that work without putting me under, and only thing that is changed is Play Animation has Attack changed to Attack 1. Even if I change Attack 1 back to Attack, which plays above ground with any normal attack on anyone, it still puts that hero under the ground Y 1.5 to try to steal.

Hopefully I am just overworking my brain and I missed something small, if not I fear I found some bugs. Looking forward to any responses. I have a video saved of what is happening, showing Mug Attack on a Giant Rat that he sinks, then the Tentacle beside it and it works perfectly if anyone wants to see what is happening. The oddest part is the hero runs on the surface to the monster. Then on Animation start to Attack/Steal he then drops down into the ground only for the animation.

Thanks in Advance to any repliers.
  • Follow Up.

    So, I removed the Mug Attack, and made it just a Heavy Strike to see if that made a difference.. it seems like anything used from my Abilities - Sword Arts, causes this sinking into the ground to happen. That Ability Type is copied from Attack and renamed only, so I don't understand why it does anything different. Even the Scripts as mentioned are copied with just Play Animation Changes in the node.
  • In light of my shop not working after a battle like another had, and a redo of the Shop Layout fixed that, I thought perhaps if I did the same thing with my issue here with the Ability sinking the Hero, it might work.

    Ok, so, I went back into Ability Types, Copied Attack again, changed to Sword Arts. Moved it to where the old one was in the list, the old one I deleted. Then went to Abilities, copied Attack, then changed it to Mug, enabled Steal, did up the added Ability Start Animation, and now it all works.

    It seems on occasion some things we do muck up maybe some older set in place things, and a redo of them from the base they evolve from fixes it up.

    I will Redo my Battle End area, maybe I can find a way to Wipe it clean, save it that way, then redo it from the tutorial and make it work also. If not it will be the only thing that isn't quite working as it should.
  • Yep, Level up doesn't want to display for me in the Victory Screen.

    I have it set from the Event like the tutorial, it shows getting items, exp and money, but will not proceed to show the Level Up when it happens.

    I have the bottom Dialogue set to Scroll and even changed that to the Menu Big just in case, and Block Focus is off so it isn't denying any other windows from showing. I have the Show Gains and Show Level Up Notification checked, I have their dialogues all set appropriately.

    Any idea why it refuses to show the Level Up on Victory anyone? I am really stumped here.
  • 1) Well, generally that's up to the battle events you're using to animate the steal ability. The actual issue could be with an animation that's just, well, looking like that, or also something physics-related, e.g. the combatant's collider being pressed down by the other combatant, etc.

    2) What Loot Dialogue Type are you using, the default Simple type?
    Also, Block Focus only blocks other boxes from getting the focus, they'd still show :)
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • 1.) It wasn't the animation for the Steal, it was something with the Status Ability/Type, I removed them and remade them both and the animation now works fine. Though I have no idea what would have done that, I didn't know of an offset to put in either for the character position. Might be one, I haven't found everything yet.

    2.) Simple Type yes, and thanks for the heads up on Block Focus. I have 2.31, I tried both Show Battle Gains First and off, neither brings it up. All I can get to show at level up is a Floating Text I made haha, That area of my Battle Texts seems to work just fine. I have them all as Default currently for the Notifications, and in my Combatant, I am not blocking any notifications from showing up, nor using Own Level Up. All I need is in the combat end, Get Battle Gains Node in place with the checks for Get Gains on. Then I should be on dream street from natural coding as you have at default as far as I remember.

    I am really stumped as to why it won't appear. I used the basis of the shell for the game using the Tutorial, and every other time it has shown the level up dialogue. Thanks again for helping me figure this out. It is one of the more major requirements I find of an RPG, seeing Lvl up Abilities and such lol. I'm rather ashamed mine is currently using a Floating Text.
  • edited February 23
    1) Hm, the only animation related thing here would be the damage type used by the ability's type, which defines the animations used for damage, evade, etc. on the hit target. Though that's only used to animate the target, not the user.

    2) I tested it with various possible combinations and it always worked for me. I assume your Level Up Texts (at the bottom of Battle System > Battle End) are set up to show some stuff?
    My guess would otherwise be that the GUI box is displayed somewhere it's not visible, maybe try a different GUI box.
    Post edited by gamingislove on
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited February 23
    2.) I have done so, I have used my Menu Big which is the largest and positioned properly for all other menus, it doesn't show. Also the Bottom Dialogue shows for Gains of EXP and Items. It just fails to proceed to the Level Up Dialogue. My Battle End is all set, kept as default For Texts in fields. I used the GUI to increase Text Size so I added nothing to those original texts.

    Status Settings in my Combatant is checked for Can Level Up. I don't have No Status Development Checked, and the Status Development is set to Player Development.
    Level Up Settings for Own Level Up is not checked.

    Battle End Base Settings, Whole Party only checked top and bottom.
    Loot Dialogue 0 has All but Immediate Collection Checked.
    Loot Dialogue Settings has all but Show Combatant Gains and Show Console Checked.
    Level Up Notification GUI Box - Bottom Dialogue.
    Total Level Up Text: %l
    Level Up Text: %n reached level %!
    The rest are all default texts also.

    I know it sees the Level up in the system, as I do gain levels, and I gain the Abilities I should at level 2 and 4. My only issue is the Level Up Dialogue Box Bottom Dialogue refuses to show up, even though it does show for Victory Gains before it should again for Level Up.

    Also, another question if I may. My Combat is set up to Store Scene, Teleport to Another Scene, do combat, collect, teleport back to stored scene. I am having a mild issue with when I return from Combat, the Camera is always pointed towards I think the North of the map. Is there a way to make the camera face in the direction the player is facing when it returns to the Exploring Scene? Look at doesn't adjust, nor with Ignore X, Y, Z on or off. Can I make it focus on his Hair for example so it always looks to the back of his head when it returns?

    (Edit) I changed from Mouse to Follow for Camera and now it does what I want it to save being able to use the mouse to rotate the screen.

    As for 1.) Yeah, it was baffling. The animation wasn't bugged or wrong, it had something to do with the Ability itself in ORK or the Type, I am unsure which as I removed both and remade them. All I did to fix it was copy Attack Ability Type and renamed to Sword Arts, then in Abilities copied Attack and rename to Mug, then went through and changed the Steal Settings to be on, and the Ability Type to be Sword Arts, the Battle Animation to the Mugattack event and then a small damage efficiency boost. And after that it worked. No clue why I was clipping some only on those old entries.
    Post edited by Melchiah on
  • So I went back to my old Project, checked the settings, fought, leveled up with the dialogue showing, everything was the same. So I went back, and in my Battle End Loot Dialogue 0, Show Level Up Notification was missing entirely. I had to create a new Dialogue and Delete the old one to get that to come back in. But even set the same as my old project settings, it is not leveling up my character.. I wonder if I remade my Combatant if it would fix it somehow now.. running out of ideas honestly.
  • Nope. I'm thinking my Project has been corrupted. I don't think it has to do with ORK itself. Luckily the project opens, so I can take the good info I fine tuned from it and make a new project and should be all good. Maybe a days set back all in all since I have all the events saved also. I'll keep you posted, but I can't see why this won't work. A few odd things happened in that Project I have never seen before. Level Up Dialogue, then Shop went Missing, then 9 Chests across 3 different scenes all ended up as the same and calling Scene ID 2 for them, all items inside were changed to whatever it was that was in the actual ID 2. Then when I turned on Level Up Class and Use Class to Level to try that one, and failed, I went back and then saw the Show Level Up Notification was missing. So at that point something in the file I think was an issue. I removed the clutter and only am importing what I was using and know is good. Sorry for boggling you on this, especially since it looks to be a cascading bug effect in some senses from my project file.
  • edited February 24
    Hm, enable Show Combatant Gains and check if you have Combine Level Ups enabled in the Combatant Gain Notification settings. If it is, disable it (and Show Combatant Gains) and try again :)
    Post edited by gamingislove on
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • That is actually what I had done. When Use Class Level failed, I went back to the original way without Combine Level Up and Show Combatant Gains checked. It didn't work either.
    I'm going to redo the project file. Already started last night.

    Some of my Assets when I started this project were 2 updates behind, so maybe updating twice during the early build gave me issues. I'll find out.
  • edited February 27
    Well, I have redone the file the last 2 days, gladly as it is way better this go.. but alas, my level up notification still fails to show up.
    This go around I only did the basics and no changes in there save ensuring
    Show Battle Gains
    Show Level Up Notification
    Show Notification
    Show Console
    Both GUI Boxes set to Bottom Dialogue.

    In Combatants Combatants, Status Settings:
    Start Level 1
    Can Level Up Checked

    Class Warrior
    Can Level Up, Not checked.

    No Status Development Not Checked.
    Player Development Set.

    The Flying Text of Level Up to 2! Still shows, I still gain the Mug ability, just no notifications on battle end that I have leveled up except my Flying Text, though Battle Gains shows up fine in the same Dialogue Box I am calling also for Level Up.

    I have ensured my Prefab for my Character is Set to Player in case that matters.
    Combatant Type Is Player also.

    No Own level Up area's checked.

    I don't know if you've been thinking about it since, but I need help again. :P
    Post edited by Melchiah on
  • Hm, could you send me a small Unity test project with your setup to check out? E.g. upload it somewhere like dropbox and send me the link to contact@orkframework.com.
    You can reduce the size if you delete the Library folder in the Unity project's folder.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited February 27
    I'm copying a backup to remove the library folder for you.. then I will zip and upload it for you sure. Thanks for the Library Tip, my project is about 46GB atm raw lol.
    Since this is the new file, I only managed to make the first scene operational before I passed out last night, there is a small issue with a few contents of some GUI boxes I have to iron out in the Menu system. As a heads up. My main concern is why the Dialogue box doesn't show up on Level up.
    Post edited by Melchiah on
  • I sent the link for the Project to the email above, thank you VERY much for the Help Gil. And Ork in general, I found it when I suggested I wish there was an RPG maker asset for Unity, then googled that and found someone had reviewed your asset and referred to it as such. I have been playing with it for 3 years now, I think I got it back in 18, and love it so much. Been slowly building up all the things I needed over that time to build a proper game with your asset and a few others to help world build as well as Modelling programs and animation suites. But none of it would be possible for me without ORK. Thank you for it and all your help, Gil.
Sign In or Register to comment.