Hi. I bought Ork Framework a few days ago and have been following the small game tutorial. Everything was working great until I got to section 33. Real Time Battles.

At this point, the tutorial reminds you to place equipment visualization elements on all your combat prefabs, so I created an empty scene for the express purpose of dragging in all the prefabs, and updating them. When I dragged them into the Hierarchy, they showed up in a few different locations, so I selected them all and zeroed their transforms so they were all in the same place to work with. (this might have been my blunder? Then I added all the empty game objects, visualizers, etc. Saved and went to test my game.

First thing I noticed was my shadow projecting out in front of me, so I fixed the location/rotation of the blob shadow projector, applied to the prefabs and tried again. this time everything looked fine until I got into the first turn based battle. The it looked like my screen or camera was glitching out. I paused and checked the Scene Viewer and saw that the swords and helmets (the white boxes) are huge!

I tried scaling the game objects containing the visualizers down, but that didn't help. it seems to happen when the combatant spawns/enters battle, since I can see it on the dudes in the area spawn, too.

How do I fix this without just restarting the tutorial? Thank you.

Post edited by Megami on
  • edited December 2017
    Haha, yeah ... that's due to the file scale of the egg model being too small, which is compensated by having a very high scale on the skeleton of the combatant's prefabs (where the equipment viewers are located on).

    Try setting the scale of the equipment viewer game objects to 0.01 on all axes.

    I'll add this info to the game tutorial :)
    Post edited by gamingislove on
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited December 2017
    While I was paused, I scaled this down, and found that, as you said, .01 was about where they needed to be. I stopped the playthrough, scaled the viewer objects, saved and tested again and they were huge again.

    It is perhaps worth noting that the swords and boxes were the right size earlier, on just BrownPants and EvilPants, when I was testing turn based, active time, and hunting battles. It wasn't until I tried setting them up on all the others (which was when I reset transforms on the prefabs) that the scale glitch started.

    I will try scaling things again. Thank you for the response!

    Edit: While I was trying to adjust the scale on the viewers I noticed that the scale on the skeletons had been reset as well. I am going to re-import just the combatant prefabs from the tutorial package. As a side note: when importing a character and rig fbx into Unity there is a scale option on the import itself. Changing the scale at import is a lot cleaner than scaling the rig, and prevents users who don't know what they are doing (in this case, me xD) from breaking things in the future. Thank you so much for providing all the help and support! I'm having a lot of fun learning how to use the Framework.
    Post edited by Megami on
  • Okay! Re-importing the combatant prefabs and setting up the equipment viewers fresh fixed everything! You don't need to edit the tutorial (except maybe to note not to mess with the transforms of the prefabs ^^; )
Sign In or Register to comment.