I'm using both Makinom and ORK together. I'm trying to create a player controller HUD in Makinom, but it doesn't show. I have a schematic that starts the game and sets the game state to In Control, this is then called by the initial ORK start event. The HUD is supposed to show when In Control, but it does not.

Any ideas as to what I'm doing wrong?
  • What's the rest of the HUD's display conditions - also, is your Makinom game started (e.g. enabling start game in the Makinom game starter)?
    Also, are you using legacy GUI or new UI?
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited June 2019
    Yes, the game is started. The HUD's display condition is that the Game State is In Control is Active and that the game is running. I'm using the new UI.
    Post edited by Dolorre on
  • edited June 2019
    It seems for some reason the Makinom framework isn't starting; none of the schematics seem to be working in Global Machines.

    EDIT: It's like the Game Starter isn't starting the game. When I attach a schematic to it, nothing happens, nothing starts. I've made sure Start Game is checked. Nope, I checked it with a show text and it works, so it's not that.

    EDIT 2: I created an empty project with just Makinom, and it worked fine, displaying the text I put into a schematic. So it's not the version of Unity I'm using. I've also tried reloading all my assets, but that didn't fix anything.
    Post edited by Dolorre on
  • Okay, I got a Schematic to call the HUD, and now it's showing. Yay!
  • how you did that? I can't seem to make the HUD working also
  • I'm running to the exact same problem
Sign In or Register to comment.