So I was working with my player prefab and messed some things, so I deleted that prefab and imported an older version of it. And after that I started to get this error message in console every few seconds:
Not a Prefab scene
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

Everything else works, I can start game without problems and change scenes. But it is really annoying to have hundreds of error messages. I've searched for this message and found nothing about it, so I guess it is somewhat related with Ork, not a Unity native.

Maybe anybody knows how to solve it? Because it kinda brokes my whole project :(
  • edited February 2021
    Oh, and also all scenes in editor is without headers.
    And my Unity version is 2019.4.16f1

    Nevermind. I tried deleting ORK Framework and I kept getting error anyway. It seems that it is some kind of Unity bug, not ORK related :(
    Post edited by Aratron on
  • Yeah, sounds like a Unity issue - since it's GUI related, do you have anything in the scene scelected while this is happening? Sounds like it might be coming from the inspector.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on!
  • @gamingislove I don't think that I had anything selected, because this happened while I was in character prefab window, then I excited it, tried if animations work, they didn't and I deleted that prefab(while it was selected in ORK framework Combatant section, if that's matter) and reimported it with that same name. And suddenly I got that errors.

    I "fixed" it only by deleting all my scenes and reassembling them from scratch. Good thing it was only prototyping scenes, with only couple of objects on them, so I didn't loose much work.

    But I tried to google that error and got two other results with the same error(and no explanation why it was and what to do with it) but none of them mentioned ORK, so I don't think that it is related with ORK.
Sign In or Register to comment.