I'm using a RotateTo node in a 2d game and it is not rotating the object to the rotation specified. Instead of rotating Y to 180 degrees (and ignoring the others), the object ends up with the rotation: -90x 0y 0z

It's unclear to me why this is happening. I tried enabling all xyz but that does not work either.


Help is appreciated.
  • I have similar issues. rotate to -> target always works just fine, but using a value does bring unexpected results.
  • The Rotate To node will rotate the game object to face a defined position or game object in the scene. So, in your image, you'd rotate to a position in world space at X=0, Y=180, Z=0.

    If you want to change the rotation manually, e.g. rorate by X degrees, etc. - use a Change Rotation node.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • That worked. Thanks a bunch for your help!
Sign In or Register to comment.