I just started developing the Menus for my game following the ORK tutorials.
While the Overview and Inventory menu work, the menu freezes when I am trying to open the Abilities and Upgrade Abilities menu Screens.
These are the errors I am getting when trying to open them:

image

image

I am still quite unfamiliar with the UI setup so I'm not quite sure what I did wrong :(
  • I'll look into the errors - can you give me more details on the setup and when the error occurs?

    E.g. are you using a combatant selection via a Combatant menu part to select a user before opening the ability menu, etc.?
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I think I found the issue, should be fixed in the next update.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • It occurs when in the Overview menu, I click the "Abilities" or "Upgrade Abilities" in the right side menu.
    So far I only have only the Player in the Overview list of combatants. If I follow the same procedure, the Inventory and Group menu work, but the Abilities, Upgrade Abilities and Equipment menu don't.

    Regarding the setup, I followed the ORK tutorials as closely as I could.
    http://orkframework.com/guide/tutorials/3d-rpg-playground/14-research-trees-menu/
    http://orkframework.com/guide/documentation/features/research-trees/)
  • A small bugfix update will be available later this week (most likely) and should solve this issue.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I just updated to Version 3.3.1
    Now when selecting these menus (Equipment, Abilities and Upgrade Abilities) I don't get any more error messages, but they still don't open.
    The other menus (Inventory, Quests and Change Group) when selected, work.
    I went over the tutorials again but couldn't find anything that was set differently :(
  • edited May 30
    Hmm .... can yo post the setup for the overview screen?
    Mainly the button that calls it (and maybe the combatant part).
    Post edited by gamingislove on
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I went through the overview screen again and eventually found the culprit!
    The screens that didn't open had Select Combatant = true.
    Thank you for pointing me in the right direction :)

    Now that I can actually see the entries I noticed that all the icons (for abilities, equipment..) in the menu are really big. Is there a way to to limit their size?
  • That depends on how you display the items.

    If they're part of the button prefab's setup, you can do that on the prefab, e.g. adding a Layout Element component to the game object displaying the icon and setting the preferred width/height.

    Or, if it's dispalyed via text codes in text, that's up to the TextMesh Pro setup.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Adding the Layout Element did the trick, thank you Nicholas!
Sign In or Register to comment.