Hi,
I have successfully completed Lesson 1 of 3D RPG Playground, now I am facing issues with the Start Menu lesson.

After setting up the UI Box, and doing everything in the lesson, there is a point in the middle where we are asked to test it by hitting play: https://orkframework.com/guide/tutorials/3d-rpg-playground/02-start-menu/#16-toc-title

Here, I am not getting the menu at all. I double checked all the steps but not sure what I am doing wrong. Would really appreciate some help. Here are the screenshots of what I should be seeing and what I am seeing instead:

I am supposed to get this: https://drive.google.com/file/d/1DULCZiHFsUZs5xu695dzm5vARq_u0skZ/view?usp=share_link

But I get this: https://drive.google.com/file/d/1sjelfWNPUK-9CRFp31Yd2-q1U7ZwtW3i/view?usp=share_link

Thanks!
  • edited November 2022
    I think I had that problem but I don't remember what I did to fix it. I mention it so that maybe the documentation for that part can be looked at.

    Update: Check cdmx's post in this thread. I think he may have meant to post it here.
    Post edited by Scyra on
  • Based on the screenshot, you still have the canvas and UI box as part of your scene - that's not how it works.

    You create a prefab out of the UI box you set up and use that prefab in the UI box that's used by the start menu. ORK/Makinom create the UI (canvas, UI box, HUDs, etc.) for you, so they shouldn't be in your set up scenes.

    Also, if the start menu isn't opened, make sure the Game Starter doesn't have Start Game enabled.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited January 8
    Not sure if issues resolved for anyone else. I had completed all my UI Box setups and fixed the sizing with canvas.
    The area the tutorial doesn't cover is inside the Makinom Settings under UI System>Default UI Prefabs, you need to make sure your buttons and boxes are selected, otherwise Makinom won't pull up the references or resources to put in the scene.

    Hope this helps, I just figured it out today after comparing the Prebuilt Tutorial Model with my model.
    Post edited by RealityPatch on
  • The tutorial lists the initial UI setup in it's first steps to do before starting the actual tutorials :)
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.