edited January 24 in General Support
Dear,

I just purchased your footstepper item. I am using unity standard asset with FPS. I am not able to get a jump/land sound with my FPS. I created a footstepper material and attached this material to the FPS capsule through footstepper component. It is playing the walk sound just fine. But no Jump/land sound even though I specified the jump and land clips on the material.

Can you please help?
Post edited by salah99 on
  • How did you set them up to be played? Jump/land are not automatically played, as footstepper has no idea when the player jumps or lands somewhere.

    You can e.g. play them via animation events or by calling them via scripting. Check out the documentation on playing footsteps for details.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Thanks a lot for your valuable input and prompt response.

    It would be very helpful if this phrase

    "Jump/land are not automatically played, as footstepper has no idea when the player jumps or lands somewhere."

    was placed somewhere in your documentation especially for newbies.

    Thanks a lot again.
  • Well, the first sentence in that documentation is: Footsteps don’t just play themselves – you have to define how and when to play them.

    That naturally also includes jump/land footsteps :)
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.