edited November 2023 in ORK Support
Hi, I have a few questions and things I haven't been able to solve on my own yet if anyone can help please.

I can't get spoiler to work with [ or with < how do I use spoilers here?

1) Quest task notifications

For example collect items, I have a notification show 1/5, 2/5 etc as you loot the items. Is there a way to set a condition on these so that when it reaches overcount it stops displaying the notification? I want to leave it on the Quest list HUD because it might say something like Return to NPC with the 5 and I want that showing so I don't want to deactivate the quest when it's finished. But I want the notifications to stop after the items are all collected.

For now what I've done is Own UI Box Schematic on the Finish Requirement Notification and I check if it's finished or not, then hide all Auto Close boxes, then turn them back on on the UI Box close schematic. This hides them when overcounted/finished, but if you happen to level up at the same time it will close the LevelUP notification too since I have that as an auto-close.

Edit ok I made sure that overcount is not checked, and it still happens. The task has Auto Finish, and yet it still shows finish requirement notification after it's full count.

2) Quest list HUD sort order.
The goal is for the player to be able to click a radio button or check box in the Quest Menu to show it in Quest List HUD or not, and for the most recently checked quest to go to the Top of the Quest List HUD.

I want the quests to all be active in order to display collection/kill notifications even if the quest is not on the Quest List HUD.

I see the Active Sort Order on t he Quest List HUD but I can't figure out how to change that weight on a quest during runtime to use it in the Quest Menu for the player to sort. I don't see any nodes for Sort order.

3) I have a Tooltip HUD for Abilities and one line is Status Text Content, set to Ability, with reuse / reusemax tags in it. I have a HUD Condition component on the Status Text Content with Condition Reuse-Has Reuse Yes
Phase battle with turn based reuse.
The condition prevents it from displaying on abilities that don't use a reuse timer, which is what I want, I don't want abilities that don't use re-use to show a blank reuse because that's confusing. Anyway

When I mouse over a shortcut that has an ability that does Not have a reuse time, there is no error.

When I mouse over a shortcut with an ability that does use a reuse time, it gives this error. But it still displays the reuse properly.

If I remove the condition, the error stops, but then of course it displays on abilities that it should not display on.

Edit: oh oops there is no scope on a Tooltip HUD so nevermind that idea.

NullReferenceException: Object reference not set to an instance of an object
GamingIsLove.ORKFramework.ReuseTime.CheckBattleSystem (GamingIsLove.ORKFramework.Combatant user) (at <54861ea135fe40f483ede6f31ef162f3>:0)
GamingIsLove.ORKFramework.ReuseTimeSettings.GetReuseTime (GamingIsLove.ORKFramework.Combatant user, GamingIsLove.ORKFramework.ActionReuseStartType startType, System.Boolean ignoreStartType) (at <54861ea135fe40f483ede6f31ef162f3>:0)
GamingIsLove.ORKFramework.AbilityShortcut.GetReuseTimeSetting (GamingIsLove.ORKFramework.Combatant user) (at <54861ea135fe40f483ede6f31ef162f3>:0)
GamingIsLove.ORKFramework.UI.ReuseHUDCondition.Check (GamingIsLove.Makinom.DataCall call) (at <54861ea135fe40f483ede6f31ef162f3>:0)
GamingIsLove.Makinom.UI.HUDCondition.Check (GamingIsLove.Makinom.DataCall call) (at <996ca35e83f140d18d4f2476ad91bad3>:0)
GamingIsLove.Makinom.UI.HUDConditionSettings.Check (GamingIsLove.Makinom.DataCall call) (at <996ca35e83f140d18d4f2476ad91bad3>:0)
GamingIsLove.Makinom.Components.HUDConditionComponent.Check () (at <a2ed8fec9dce4568b9d8c91265c02460>:0)
GamingIsLove.Makinom.Components.HUDContentProviderComponent.FireChanged () (at <a2ed8fec9dce4568b9d8c91265c02460>:0)
GamingIsLove.Makinom.Components.HUDContentProviderComponent.ForceUserUpdate (System.Object newUser) (at <a2ed8fec9dce4568b9d8c91265c02460>:0)
GamingIsLove.Makinom.Components.HUDContentProviderComponent.set_User (System.Object value) (at <a2ed8fec9dce4568b9d8c91265c02460>:0)
GamingIsLove.Makinom.UI.TooltipHUDInstance.TooltipChanged () (at <996ca35e83f140d18d4f2476ad91bad3>:0)
GamingIsLove.Makinom.UI.TooltipHandler.FireTooltipChanged () (at <996ca35e83f140d18d4f2476ad91bad3>:0)
GamingIsLove.Makinom.UI.TooltipHandler.Tick () (at <996ca35e83f140d18d4f2476ad91bad3>:0)
GamingIsLove.Makinom.UI.BaseUIHandler.Tick () (at <996ca35e83f140d18d4f2476ad91bad3>:0)
GamingIsLove.Makinom.Maki.FireTick () (at <996ca35e83f140d18d4f2476ad91bad3>:0)
GamingIsLove.Makinom.MakinomHandler.Update () (at <996ca35e83f140d18d4f2476ad91bad3>:0)

4) Phase battle Player Combatant Selection -> Allow Clicking is enabled.
Sometimes when I click a combatant on the grid I get an error but it's like 1 in 10 clicks.
The error does not occur when selecting a combatant by clicking a combatant on the player group HUD (Using HUD Click component -> Select Target
It also does not occur if selecting combatant from a player selection menu UI Box.
I tried disabling all of my current selection prefabs like grid prefab change, world HUD change (HP bar/name bar) thinking maybe something with swapping to the other HUD/other grid hex but that wasn't it.

ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
System.Collections.Generic.List`1[T].get_Item (System.Int32 index) (at :0)
GamingIsLove.ORKFramework.PhaseCombatantControl.get_InputID () (at <6f1b2b7409b84f14a24acdc04828e07b>:0)
GamingIsLove.Makinom.Components.UIBoxComponent.Tick (System.Single delta) (at <75be63ef657b4d40abf452d6950f5f85>:0)
GamingIsLove.Makinom.UI.BaseUIHandler.Tick (System.Single t) (at :0)
GamingIsLove.Makinom.UI.BaseUIHandler.Tick () (at :0)
GamingIsLove.Makinom.Maki.FireTick () (at :0)
GamingIsLove.Makinom.MakinomHandler.Update () (at :0)

5) I get a culling error message but the strange thing is it happens on my Start menu scene where there is Nothing loaded yet except the Main Menu UI Box and a background image, that's it.
Is it because Unity is preloading some other assets that are not using culling properly? I don't have any code that I've written that use culling so it's some asset store asset I guess.

Culling group was not disposed. You have to call Dispose explicitly from the main thread. This will likely result in a crash.
UnityEngine.CullingGroup:Finalize ()

6) Ability tooltips for abilities on shortcuts if the ability is using a Percent cost rather than a flat cost, it is showing the value of the percent of the Ork Player or leader instead of the combatant that is actually using the ability. Strangely the shortcut Info displays it correctly for the current combatant. How do I make the tooltip use the combatant whose turn it is for ability cost?
Edit: I noticed that the reuse status text on the tooltip also only shows a value if it's on the leader/Ork Player. So other combatants in the group always show 0 reuse remaining. Could this be related to question 3?

7) I have some combined value status values that use a formula. I have a stats menu displaying the status values for combatants. If I equip a piece of equipment that increases a combined value, the HUD shows the updated value in the menu. However if I increase it via a Status Effect, it does not update in the menu. If I look in inspector I can see that the status effect is working, it has increased the value the appropriate amount. I don't quite understand why equipment displays and status effect does not.

8) On status values the check box for Use Changed State. Can you explain the functionality of this? I'm confused by the tooltip. Uses the changed state upon receiving value changes. Does this mean if say a status effect reduces your Strength, if this box isn't checked it won't use the reduced value for formulas? It will use the original value without the changes from the status effect? So like this should be checked on any status value that might be debuffed by a status effect?

9) Is there a way to limit a shortcut list to only certain shortcut types? I want a shortcut bar that is only for items, not abilities. I set it all up as items and it still allows me to drag an ability to it. The shortcut will not display the ability, the slot appears empty, but it's there because the tooltip shows with mouseover and I can click to use the ability.

10) This is my big game breaking one here. Every now and then the turn order somehow breaks and a combatant is stuck unable to select them, but they have the selected combatant grid highlight on them (which is also on for the actual selected combatant whose turn it is) and their turn will be 1 off from the rest of the group. I've been struggling to reliably reproduce it. Once I had it happen upon joining a battle grid, moving 2 combatants, and then clicked the 3rd and it bugged out. So that showed me it wasn't anything to do with an ability or combat since it was a fresh battle and nothing had happened but moving. I was thinking it could be to do with Auto End in phase setting or auto start turn Phase Start so I'm going to test turning those off, but of course I want them on.

I'm trying to test if it only happens when clicking a combatant on the grid to select them as it may be related to the other error message, but that message doesn't come up when this happens so it probably isn't related

I realize this is not going to be enough information, I'm going to continue to try to reproduce it. I've made a turn start and end schematic displaying the turn number of player combatants to unity log so I can try and catch exactly when it happens.

Post edited by GeneralK on
  • I don't think the text editor here supports spoilers.

    1) Notifications shouldn't be displayed, unless you enabled Allow Overcount.
    Will look into it, might be a bug.

    2) There are currently no options for that.
    The active/inactive sort order options are used for general quest list sorting, e.g. to define some special quests to be sorted before others. Otherwise they are listed in the order they are added to the player's quests.

    3) Yeah, that's a bug, will look into it.

    4) Will be fixed in the next update.

    5) No idea, but I doubt it's coming from ORK :)

    6) The main issue here is that the tooltip (or HUD displaying an ability) only has access to the ability, and no link to the combatant it belongs to, so it uses the player in that case.

    7) Status effects aren't fully supported in previews.
    They generally only show stuff added via status bonuses, but not from status changes.

    8) Status values can optionally use changed state information.
    When enabled, you can display additional information in HUDs, e.g. the last change that was done to the status value or the last combined change (i.e. multiple changes combined). The UI > Text Display Settings have options for the combined change times.

    This'd mainly be useful for e.g. health to display total damage from the last few changes (e.g. dark souls style damage numbers on the health bar).

    9) No, shortcut slots are universal and currently can't be limited to a specific type.

    10) Yeah, I need a Unity test project and a way to reproduce this happening :)
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited November 2023
    @gamingislove Thanks much as always for taking the time to help!

    1) Task notifications. I went through all of them and none have overcount checked.
    Edit again. It does not happen when looting the item from item collector on a combatant corpse that only has 1 item being collected (multiple of the one item that is) for the task.

    However when a schematic spawns prefab with an itembox on it and uses AddToItemBox node, looting from there shows the notification even when the count is done and overcount is disabled.

    This is on tasks that have multiple items to collect, so the task itself is not finished out. Thinking its possibly nothing to do with addtobox node but is because of multiple items being collected on 1 task so like 2 spider legs, 2 spider eyes, 2 spider silk all on 1 task it keeps notifying.

    2) Quest sort order. Ok so if I put it back to using Active/inactive to use as sorting, is there a way to keep notifications displaying on inactive quests? I've been looking through the settings and not seeing how to do it. The goal is to allow player to choose which quests are showing in the HUD list (limited), but also have other quest notifications still happening for quests not displayed on HUD.

    6) Ability shortcuts. That means that use costs, reuse costs, anything combatant specific can't be used on a tooltip for a hotbar? (with a setup that has multiple classes/combatants that have different skills at least) I guess as a workaround I'll just add to the description on the abilities things like "Cost 10% mana" and then just let the Info on the shortcut have the real number.

    7) Status value HUD. Edit again because getting confused on this one.

    Ok so it is a Status Value List of Ork HUD Status text content prefab, set to Status Value, and the HUD is called in a Menu via a Combatant menu part.

    Status effect with a regular status value like say Custom Bonus -> Status Value -> STR +1 updates the HUD instantly increasing STR by 1 on the HUD.

    Status value called MeleeDEF uses combined value in the SV settings, a formula that is say STR+AGI+DEX

    When I cast the Status Effect that is +1 STR it updates MeleeDEF and STR on the HUD as it should.

    But if I change the status value bonus to directly increase MeleeDEF instead of STR, it doesn't work.

    So I guess you can't directly increase the value of a combined status value?

    I think I was looking at the wrong sv line in inspector when I thought it was working.

    10) Wacky turn order. I caught it in my turn schem logging but don't have the screenshots with me here. Basically 1 player group member did not End turn when the rest did some how, but started the next turn, and that group members turn number is off by 1 from the rest of the group.

    I'll work on a test project, but I guess I need to try and more reliably reproduce it first because sometimes it doesn't happen until I've played for a couple of hours lol.
    Also I use UMA for my armor sets, have a ton of different models so I'll have to figure out a test scene with limited combatants and strip armor off the player and stuff I think to make it small enough. My assets folder is quite huge lol.

    Anyway thanks again, I always feel dumb posting bad questions haha +D

    Post edited by GeneralK on
  • 10) Wacky turn order turn log schems.

    3 combatants in player group.

    Leader Start turn 11
    playercombatant1 Start turn 11
    playercombatant2 Start turn 11

    Leader End turn 11
    playercombatant1 End turn 11

    Leader Start turn 12
    playercombatant1 Start turn 12
    playercombatant2 Start turn 12

    Then in inspector

    playercombatant2 has turn 13 and Is Choosing as true, but leader also shows Is Choosing True.

    I see a difference between them on Waiting for Action is True for leader, False for playercombatant2.

    Anyway might not help anything but it's a start. Maybe I'm not using the correct End somewhere and it's ending phase instead of turn? But I distinctly remember this happening in a battle prior to any combat happening so that doesn't make sense hmmm.

  • 1) Yeah, notifications being dispalyed when the full count was reached for a requirement is a bug and will be fixed in the next update.

    2) There's actually the HUD Click component available to handle things like this.
    E.g. if your quest menu uses HUD content, or the quest HUD directly, you can use the component's Toggle Quest Visible click type to turn on/off a quest being visible in the HUD.

    6) I'll look into it.

    7) Is the combined value formula actually using the MeleeDEF status value itself?
    Otherwise bonuses added to the stat are lost.

    10) Are actions strictly used via the battle order/system (i.e. players via battle menu or whatever input you use, enemies via battle AI, etc.), or are you e.g. using actions within actions (e.g. using Use Battle Action node)? That could disrupt the turn order.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Ok thanks again as always for your help.

    5) Culling group error: I know this is outside your scope GiL but just incase someone had an idea. It's so weird because I went through every scene and Only the Start scene has the error. There is nothing in the start scene except the Start menu UI Box from Ork, camera, Ork game starter, and a background image. It's like an empty scene. It also doesn't happen every time I hit play, it's like 1 in 3 it errors.

    7) Status Value list/Status Effects: Does this mean that if you want a character stat sheet to show a buff/debuff it has to be done as Status Bonus in the Status Effect in order to display it?
    Am I doing something wrong with using Status Value List HUD for a character sheet or do I just need to change any Status Change buffs/debuffs to a Status Bonus if I want it to display in HUD? Like should I use something else to display char stat sheet? The difference being can't use formulas for Status Bonus like you can Status Change, so can't do things like Min/Max value in a Bonus.

    10) Turn order problem: Ok I tested it more and it's happening when I End Turn. (Phase battle, ending turn for a combatant)

    I had a control map that was set as Action -> None that I was using, and also had a shortcut bar with auto-assign None to a slot-index, with a control map for the shortcut slot-index. (Accidently having 2 control maps same key on space bar)

    Once I realized it was happening on End Turn and not from abilities, I dragged End Turn from the battle menu on to a regular shortcut bar and then proceeded to test only using that hotkey to end the turn and the issue hasn't happened again since. Hopefully it's not just coincidence, don't want to waste your time, but it hasn't happened again in 10 hours of play testing, yet.

    11) Grid move combatant thunk to ground or walk in the air. I'm feeling pretty newb on this one not getting it. I posted this in another persons' thread but thought to consolidate all my questions to this 1 thread. https://forum.orkframework.com/discussion/8505/issue-with-movement-using-the-grid-system-in-3d#latest

    Using char controller, place on ground on prefabs. After my combatants move they can thump to the ground a small amount or some of them floating even though they have place on ground. Some of them I've been able to adjust character controller and get it to stop/almost stop but if it goes .01 too low then animations stop playing. This seems to tell me its my not getting Char Controller lined up correctly but doesn't feel like it should be this hard and temperamental to have to line up the char controller so precisely on every prefab?

    I tried changing move component in grid move schematic to Transform because of that other thread, and it actually stops the feet thump to the ground, but then animations no longer play. If I manually play the animation using Play Combatant animation -> Move, it does play but it has a delay before it starts. Auto animations mecanim.

    I feel like I'm simply not understanding the move components and grid correctly. Some of my battle grids have an offset different than others, could that be why? If grid is not the same Y as terrain?

    12) I think this first happened after updating to 3.16.2 but may be unrelated. I'm fairly certain I had already saved the editor settings several times prior to this error, which is weird. Everything seemed ok, I didn't notice anything not save and I've saved a hundred times since without the error happening again.

    Warning! An issue occured while searching for variables after saving.
    UnityEngine.Debug:LogWarning (object)
    GamingIsLove.Makinom.Editor.ProjectSaveHandler:SaveData ()
    GamingIsLove.Makinom.Editor.MakinomEditorWindow:OnGUI ()
    UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&)

    13) This only happened once and it was when loading a saved game. Do I have my music configured wrong somewhere or a corrupt clip? I didn't change the music object for that area or anything but it does have a music object with trigger at the spawn point for save point there. Maybe from more than 1 trigger type enabled? Or it's saving the position in the music clip and can't load that position?

    C:\buildslave\unity\build\Modules\Audio\Public\sound\SoundChannel.cpp(343) : Error executing result (An invalid seek position was passed to this function. )
    UnityEngine.StackTraceUtility:ExtractStackTrace ()
    GamingIsLove.Makinom.MusicAudioSource:set_time (single)
    GamingIsLove.Makinom.MusicChannel:SetTime (single)
    GamingIsLove.Makinom.MusicChannel:PlayFromTime (GamingIsLove.Makinom.MusicClip,single)
    GamingIsLove.Makinom.MusicChannel:LoadGame (GamingIsLove.Makinom.DataObject)
    GamingIsLove.Makinom.AudioHandler:LoadMusicChannels (GamingIsLove.Makinom.DataObject)
    GamingIsLove.Makinom.AudioHandler:LoadGame (GamingIsLove.Makinom.DataObject)
    GamingIsLove.Makinom.SaveGameHandler:Loaded (GamingIsLove.Makinom.DataObject)
    GamingIsLove.Makinom.Components.SceneChanger/d__26:MoveNext ()
    UnityEngine.MonoBehaviour:StartCoroutine (System.Collections.IEnumerator)
    GamingIsLove.Makinom.Components.SceneChanger:OnSceneLoaded ()
    GamingIsLove.Makinom.Maki:FireSceneLoaded ()
    GamingIsLove.Makinom.Maki:OnSceneLoaded (string,bool)
    GamingIsLove.Makinom.MakinomHandler:OnSceneLoaded (UnityEngine.SceneManagement.Scene,UnityEngine.SceneManagement.LoadSceneMode)
    UnityEngine.SceneManagement.SceneManager:Internal_SceneLoaded (UnityEngine.SceneManagement.Scene,UnityEngine.SceneManagement.LoadSceneMode)

  • 5) Have you tried removing the camera and adding a new one?
    Or just redoing the whole scene :)

    7) When applied, all those changes will be visible on the stats, but previews values currently only use those coming from status bonuses of effects, not from status changes.
    I've got this on my to-do list to add previews for those as well, but only coming from stuff that's added on Apply, i.e. there'd still not be a preview for time/turn based status changes of effects.
    You only need to change the status effects for this to work, the (HUD) status value list only displays the information.

    10) Would depend on how that control map key/action is set up. E.g. Is Silent enabled could lead to that.

    11) Place on ground is only used on spawning (or when scene was loaded when used on other stuff in the scene), so that doesn't place the combatant on the ground each frame.

    If you're using Mecanim, I'd recommend to forward movement speed to the animator controller and play idle/movement animation based on that, e.g. as it's used in the 2D tutorials or the 3D action tutorials. The auto animations are best only used with legacy animations.
    Are you using root animations?

    12) That functionality is wrapped to not impact anything else and the warning can be ignored. The only issue it leads to is that the variable popup lists might not list all variables from the entire project.
    Though, it might hint at some data/asset being corrupted ... you can try in Editor > Variables to scan for variables in settings, scenes, prefabs and schematics separately and see if you get an error/warning somewhere.

    13) Hm, yeah, seems like it.
    Did you change the used music clip somewhere? E.g. the save game could save music at position (seconds) 250 while the new clip is only 150 seconds long.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited December 2023
    5) Hah duh, thanks GiL I was sure overthinking that. I recreated the scene and haven't had it happen again yet

    7) Status Value HUD list - after reading what you said I realized it's not just a simple SV not working/displaying so did more testing.
    If I cast a buff that buffs MelDEF (combo stat STR/AGI) using Status Change, then open the HUD it does not show the buff on the stat(shows default value).
    If I equip an item that has STR (contributes to MelDEF) then the HUD updates and shows the MelDEF increased by the Status Effect buff + the item STR (correct value).
    Then next step, if I equip an item that has no contributing stats to MelDEF, the MelDEF stat changes back to as if no Status Effect (did Not remove STR from item, it still displays). Taking off the non-str item does not update it back again but adding another STR item does. I don't understand why adding an item that doesn't have STR/AGI would stop displaying the correct value.

    Inspector shows the correct values the entire time, including from initial buff from Status Effect with no equipment equipped.

    It also happens in reverse with STR item so if I do this order;
    Add buff (doesn't display)
    Add STR item (displays buff + str item)
    Add INT item (displays str item value only, no buff)
    Remove STR item (displays buff only, as it should, INT item still equipped)

    Maybe need a video on this one hehe.

    10) Turn order problem - Hmm ok I'll try using the control map again, 1 control map, without is Silent enabled

    11) Ok thanks for the help I'll work on that next
    12) Cool thanks
    13) Ah yea I had moved the save point/spawn point and the music collider was not centered with them oops.

    Thank you very much!
    Post edited by GeneralK on
  • 7) Uh ... are we talking about previews (i.e. the predicted value changes when while having something selected) or changes coming from an actual status change (e.g. after applying the effect or equipping something)?
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited December 2023
    7) actual status value change which is why the confusion on this question hehe. I kept trying to understand what i wasnt getting about the use of the word preview, but it's not a preview it's actually casting a buff and actually equipping equipment.

    Status value list hud called from combatant menu part, and status value change from a status effect. Menu has equipment part and inventory exchange so the status value hud is updating on inventory change. It works fine and I see status values and attack modifiers update as I change equipment, but then noticed this issue happening with melee defense.

    I can send a short video clip to your email if needed. I've started working on a stripped down test scene that won't require gigs of assets to send for future issues but its not ready.

    Post edited by GeneralK on
  • 7) Yeah, I think a video or test project would be best :)
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Hi GiL,

    I'm having an issue with Menu Screens after updating to 3.16.3

    A bunch of my menu parts show no settings. It looks as if it's minimized but it's not.

    When I move a menu part up some settings appear but then lose some settings.

    I created a new menu but adding menu parts appear blank. Sometimes it's the 2nd+ part is blank, sometimes it lets me keep adding them and is ok, sometimes it seems like a certain combo will work like Inventory+combatant parts will appear normal but then doing Equipment+Inventory the inventory was blank, then I remade it with Inventory first and equipment showed up.

    Then if I move them up above a completed part, the completed part loses some settings like input prefab, equipment slots, but the blank part shows up.

    Then I noticed that on some settings will appear again if I minimize other menu parts.

    Getting this error like every time I click on move or minimize, but I've had that error a long time and you had said it didn't do anything before.

    GUI Error: Invalid GUILayout state in MakinomEditorWindow view. Verify that all layout Begin/End calls match
    UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&)

    Anyway is there some limit to the # of menu parts you can have on a menu?

    Unity 2021.3.8f1


  • Did some tests with menu screen part combinations and didn't run into this. Could be depending on the setup of the parts, so that'll be hard to find without details.

    Can you give me some details on specific setup (e.g. screenshots from a menu where this happens)?
    Or send me a Unity test project to check out directly.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited December 2023
    I reverted to a version of my project just prior to patching 3.16.3, took video of the settings (it's 8 menu parts so kind of hard to screenshot it all), then installed the patch and took another video of the parts being buggy.

    Then I tried restoring backup of Ork from prior to patching, thinking that it would reload the menu parts settings but still keep the new patch, but the menu parts are still bugged and missing some settings.

    When I add back Equipment slots and inventory containers to parts, then save, then click back on those parts the slots are gone again, took a video of that too.

    Sent you an email

    Also when I restored the backup I got a bunch of warnings on Quests.
    Should I worry about these warnings? Maybe it's because I copied quests and renamed them to new quests?

    "Main Object Name '23 - Get Bone Chips' does not match filename '23 - Get Bone Chips.'"

    Same message for like 20 quests

    Post edited by GeneralK on
  • edited December 2023
    Seems like this happens when Show Equip Box in the Equipment Box Settings is disabled, blocking all settings afterwards.
    Will fix that in the next update, meanwhile you seem to be able to access the settings via the limited view.

    Is this happening in other menus without an Equipment menu part?
    Post edited by gamingislove on
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited December 2023
    Ah yea, that explains why other menus are not effected since it's equipment part.

    The thing is that even with limited view I can't save equipment slots on the 2nd equipment part. I suppose I could split that part in to another menu.

    In the mean time I'm just running 3.16.2 no big deal.

    Thanks for the help as always!

    Oh what about the quest warning message?

    I assume it's harmless because all the quests function okay.

    Post edited by GeneralK on
Sign In or Register to comment.