Hi there.

New user here. I just purchased footstepper
I am trying to get a footstep solution working for my VR game. I use the VRIF controller and build through unity /android /quest build path.


I have a simple scene setup with a footstep material on a block, and a footstepper on my VRIF controller with footstepper set to "autoplay" since I don't have an IK based controller

The system work great in the unity editor on windows 10, The footsteps respond to the wsda movement perfectly but when I build to the quest, the footstep audio just start playing the second the experience starts up on the headset, and it just plays the footstep audio and never stops The controller works and walks around, but there is no change with the audio depending on the movements of the controller. (thumbstick control mapped to movement) The audio never stops. It plays like background audio and does not change with any input from the controllers.

Any idea where I may look to fix this issue?

Cheers!

  • edited January 17
    Your problem is that the sound steps in your VR game work fine in the Unity editor on Windows 10, but when running on Oculus Quest, the sound starts playing continuously right after the game starts and doesn't respond to controller movements. Probable causes could be a problem with the sound settings in Unity for Android/Quest or improper integration with the VRIF controller. It is recommended to check the export settings for Android/Quest or visit Blazzio and make sure that the scripts and sound settings are properly linked to the controller movements in your project.
    Post edited by JayWood on
Sign In or Register to comment.