edited October 10 in ORK Support
So...

My previous combination was Unity 5.4.xsomething, and ORK 2.09, I think... Earlier, after backing up my projects like a good girl, I installed Unity 2017 on a different drive and tested with ORK of a back-up copy of my project. Everything ran fine.

So, I updated to newest version of ORK and now I get this NullReferenceException, preventing me from doing anything. I don't understand what this is referring to...

NullReferenceException: Object reference not set to an instance of an object
ORKFramework.DragHandler.CheckBattleCursorOver ()
ORKFramework.DragHandler.Tick ()
ORKFramework.ORKCore.FireTick ()
ORKFramework.ORKHandler.Update ()

(My transferred ORK project is in its very very early stages... No more than a guy running around, talking to some people... no battles of any kind yet even on the horizon)

Thanks!
Post edited by Deschanna on
  • Hmm ... I'll look into it - think you can send me that test project to contact@orkframework.com (e.g. upload it on dropbox or google drive and send me the link)?
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • Thanks. Yeah, I'll strip that test project down to its basics (remove what I don't need 'cos it's sort of an uploaded products dump where I test everything so it's huuuge) and upload it on either place and link you to it. Let's get back to that...
  • Took a look into the code - by any chance, is your scene's camera not set to be the main camera?
    I.e. tag MainCamera should be set on it, which is standard for cameras in a new scene.
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • Thanks @gamingislove !
    I was still in the process of cleaning of my product dump of a test... :)
    But you solved it. I'd never have thought of that... from that!

    I have two cameras in the scene, both are tagged individually and used by a script which finds them, part of customs control/camera...

    Well, knowing what to consider, I solved that. Thanks.

    I wonder, did something change between the versions since previous used had no problems with no main camera tagged..?
  • Well, there's always a lot changing, everywhere :)
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • So true @gamingislove !

    Btw, if I could trouble you with one more thing...

    About the save game menu, after you save the game, it reverts back to the original save game menu, with save, load, cancel and to quit the save menu and continue playing, you need to cancel out of the menu.

    Is there any way it could directly clear the screen after saving, without manually having to cancel out of the "re-opened" save menu? That would be so convenient!

    I tried through events but only if I bring up only save menu it clears after save is done but I'd really like all the options on a save point menu
  • If this is for a Save Point in the scene, that's handled by the Close After Save setting in Menus > Save Game Menu > Save Point Settings in the Save Button settings.
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • Thanks. I looked and looked, how on earth did I miss that? Ah well, cool, will check it after work!
  • Oh yeah. It was while I was still on the old version. Yup, current has it. Found it no problem. Thanks :)
Sign In or Register to comment.