GiL, I encountered a huge problem when I tried updating to the newest makinon in the asset store. I am using 2017.1.0f3.

I imported makinom into my project. When I tried to open up makinom, an error pops out in the console.
TypeLoadException: Could not load type 'Makinom.Editor.MakinomAssetHelper' from assembly 'MakinomEditor, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.
MakinomWindow.Init ()
I then tried to open up makinom a second time, and this time it crashed unity and closed everything. I opened up unity again, and this time opening makinom works, but then it broke something huge. I can't open all of my other scenes at all. Whenever I tried to click on it to open it, and error just pops out.
TypeLoadException: Could not load type 'UnityEditor.PlayModeStateChange' from assembly 'UnityEditor, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.
UnityEditor.AssetDatabase.OpenAsset (Int32 instanceID) (at C:/buildslave/unity/build/artifacts/generated/common/editor/AssetDatabaseBindings.gen.cs:275)
UnityEditor.ProjectBrowser.OpenAssetSelection (System.Int32[] selectedInstanceIDs) (at C:/buildslave/unity/build/Editor/Mono/ProjectBrowser.cs:999)
UnityEditor.ProjectBrowser.OpenListAreaSelection () (at C:/buildslave/unity/build/Editor/Mono/ProjectBrowser.cs:986)
UnityEditor.ProjectBrowser.ListAreaItemSelectedCallback (Boolean doubleClicked) (at C:/buildslave/unity/build/Editor/Mono/ProjectBrowser.cs:1046)
UnityEditor.ObjectListArea.SetSelection (System.Int32[] selectedInstanceIDs, Boolean doubleClicked) (at C:/buildslave/unity/build/Editor/Mono/ObjectListArea.cs:819)
UnityEditor.ObjectListArea+LocalGroup.HandleMouseWithDragging (Int32 instanceID, Int32 controlID, Rect rect) (at C:/buildslave/unity/build/Editor/Mono/ObjectListLocalGroup.cs:299)
UnityEditor.ObjectListArea+LocalGroup.DrawItem (Rect position, UnityEditor.FilterResult filterItem, UnityEditor.BuiltinResource builtinResource, Boolean isFolderBrowsing) (at C:/buildslave/unity/build/Editor/Mono/ObjectListLocalGroup.cs:860)
UnityEditor.ObjectListArea+LocalGroup.DrawInternal (Int32 beginIndex, Int32 endIndex, Single yOffset) (at C:/buildslave/unity/build/Editor/Mono/ObjectListLocalGroup.cs:203)
UnityEditor.ObjectListArea+Group.Draw (Single yOffset, Vector2 scrollPos) (at C:/buildslave/unity/build/Editor/Mono/ObjectListGroup.cs:139)
UnityEditor.ObjectListArea.HandleListArea () (at C:/buildslave/unity/build/Editor/Mono/ObjectListArea.cs:1363)
UnityEditor.ObjectListArea.OnGUI (Rect position, Int32 keyboardControlID) (at C:/buildslave/unity/build/Editor/Mono/ObjectListArea.cs:564)
UnityEditor.ProjectBrowser.OnGUI () (at C:/buildslave/unity/build/Editor/Mono/ProjectBrowser.cs:1783)
System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222)
Rethrow as TargetInvocationException: Exception has been thrown by the target of an invocation.
System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:232)
System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MethodBase.cs:115)
UnityEditor.HostView.Invoke (System.String methodName, System.Object obj) (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:272)
UnityEditor.HostView.Invoke (System.String methodName) (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:265)
UnityEditor.HostView.InvokeOnGUI (Rect onGUIPosition) (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:232)
Of course, if I delete Makinom from my project and restart unity, then everything works again. Is it because Makinom is not playing well with my version of unity? I have a reason why I must only use the 2017.1.0f3 for my current project.
  • edited June 19
    Hmm, I also had an issue with Makinom that caused me to delete it from my project - I run the same version of Unity :o - actually I run 2017.1.1f1, my bad
    Post edited by Natnie on
    image
    Olive Branches ~ in development ~ now with a WEBSITE!!!
  • Check if Makinom was imported twice (i.e. you'd have 2 of each DLL file in Assets/Makinom/DLL). That'd cause such errors.

    Another issue could be using the wrong Makinom version for your Unity version. Make sure to download and import Makinom with the Unity version you want to use it for. E.g. if you previously downloaded it in Unity 2018 and import it in Unity 2017, you'll get errors due to code base changes in Unity.
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • edited June 20
    Natnie, that's close enough :D
    So you deleted it and never use it again? If that's the case, I plead you to try again, as makinom is one hell of an asset.

    I've checked the dll file and there were only the makinom.dll and makinomcore.dll files. No duplication.
    Hmm maybe it's because about three weeks or so I downloaded unity 2018, opened a backup project in it, and downloaded and imported makinom from the unity asset store window? But if that's the case, how do I redownload makinom? All I see from makinom in the asset store is the IMPORT button.

    EDIT: Yes, I can confirm, it's because of the import button. I went into the free makinom version, download it, and import into my project. Everything works as intended again. Of course, if I reimport the pro version, same error pops out. If this is so, then won't I be unable to use the pro version for now on this unity version, until you release a new makinom version so that the download button can reappear again? I don't mind, as the free version has everything the pro does, and I do not need access to the source code anyway.
    Post edited by Shadow_Fire on
  • @Shadow_Fire - if you delete the downloaded file, the Asset Store window will show the Download button again.

    The default location for downloaded assets is C:\Users\[userName]\AppData\Roaming\Unity\Asset Store-5.x

    Inside that folder, they are divided up by vendor name and then the asset category.
  • There you go! Thanks a lot, Keldryn. That did the job.
Sign In or Register to comment.