When I use combatant spawners, I often (not every time) get that error message in the console:

NullReferenceException: Object reference not set to an instance of an object
ORKFramework.Behaviours.CombatantSpawner.OnDestroy () (at :0)


Any idea why and how I could remove it?
  • Hm, strange - not happening here (and I don't really see how this could happen, code-wise).
    Which ORK/Unity versions are you using?
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • 2019.4.1f1 and ORK 2.30.1. However, I have this error since many months and I was on a different Unity version then.

    The error doesn't happen every time I run the game and stop though... And it only happen when I stop the game, so it's not very inconvenient... I simply wanted to know.

    I am currently unable to tell what I do that could trigger the error. I can run the game 2 times and the error will happen once... Or so it seems.
  • I get this too. Every time, for every combatant spawner, when I stop the game. If I have 6 combatant spawners, I get this message 6 times when I stop running the game. It doesn't seem to cause any problems really, but it is always there, every time.
  • Did some tests and this doesn't really happen here. Could you give me some details on your combatant spawner's setup?
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Hello, I have the same issue ...
    My combatant spawner setup:
    1
    2
    3

  • Thanks, I'll look into it and do some tests with that setup.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Good news, I managed to find the issue - since it only occured when having the ORK editor open while playing (and stopping) the game, it never happened for me due to usually closing it for play/testing :)
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.