edited September 15 in ORK Support
Hi, I did according to the tutorial but things seem to go wrong really soon.

In adding a game starter part, it asks to Double click on 0 Main Menu to open the scene.
I did double click but it doesn't seem to respond.

Then during the testing in tutorial step 2, the menu box is misplaced.

https://i.imgur.com/svj7X0F.jpg


The value is correct and the height adjustment is set to auto, anchor set at middle center, had been saved. However the menu box refuses to appear in middle, no idea why.

https://i.imgur.com/b7MKvM3.jpg

I also watched the two tutorial video on youtube and tried dragging the icon, but the menu still is replaced.

Where did I make a mistake? Any help would be appreciated, thanks.

I'm using windows 7 home premium
Unity 2017 1.1f1
Ork the trial version (2.13.2)
Post edited by sorrowofwind on
  • go for upper left anchor.

  • I tried several but all seem to stay in odd places. :?

    anchor

    Lower right

    https://i.imgur.com/O3OMlgl.jpg

    middle right

    https://i.imgur.com/W4b7jTr.jpg

    upper left

    https://i.imgur.com/8sZ7shz.jpg
  • edited September 15
    leave it as it is (upper left), and go to the layers (default layer) and press own gui layer, and go for scale to fit and middle center
    Post edited by dlevel on
  • I assume to change the setting to this?

    https://i.imgur.com/HtKre5d.jpg


    The position changes a bit but still not in center.

    https://i.imgur.com/m9I92Bo.jpg
  • edited September 15
    edited my previous message, yes the settings on your first pic, default layer, go for middle center. in the gui box go for upper left, and you might want to add another layer and use it on your main menu gui box, so the default one stays as it was so it doesnt harm your tutorial process.

    also let me know what video you mean and what dragging maybe i can help you
    Post edited by dlevel on
  • edited September 15
    OK, changed the settings to these.

    GUI setting

    GUI anchor -> middle center

    gui box -> upper left

    Now it looks like this.

    https://i.imgur.com/Uwbbuhl.jpg



    The dragging youtube video is here

    ORK Framework Tutorial: Video 2 - Setting Up and the Main Menu



    6:52 to 6:54




    By the way, a dumb question here but why does this happen to me but the videos and others don't seem to have that many problems?
    Post edited by sorrowofwind on
  • well shit... these are the settings I have on mine, but yet again I might have other settings that I dont remember ( I did these 2 years ago ) so I guess go back to your settings like in the tutorial and wait for GIL :)
  • edited September 15
    Yeah, sorry - my bad, the Default Screen Size for new ORK projects has been changed recently and I forgot to update the game tutorials on that matter :)

    See here for changing the default screen size.
    Post edited by gamingislove on
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • Gets it working now. Thanks, GIL. :)
  • edited September 15
    Sorry for the bump but at tutorial part 3 I met the cannot open scene problem again like at tutorial 1.

    When I press the town file twice (or use open with right mouse button) from scenes, the file names does change to 1 town.unity, however going to the scene screen enters to the 3d blue screen without the land.

    https://i.imgur.com/Zk9Uiq0.jpg
    Post edited by sorrowofwind on
  • That's strange, and definitely not happening on my end. Anyway, make sure your Unity scene names and the scene names you define (e.g. in the main menu settings when defining the new game scene) match, and the scenes are added to the Unity build settings (as explained in game tutorial 1).
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.