So I have setup my horizontal and vertical axes for menu input using 3 ORK inputs:
1) An axis button down
2) An axis button hold with delay
3) An aggregate of both 1 and 2

Button Down:
image

Button Hold:
image

Aggregate:
image

This works perfectly in the main menu, but in the battle menu only the hold mechanic seems to be working.. So in order to move the cursor at all i have to hold it for half a second and then it starts moving pretty quickly.

What am I doing wrong here?
  • Why are you using such a complicated setup in the first place?
    A regular Hold input without any timeouts is enough for handling menu input, as the Cursor Timeout setting in Base/Control > Game Controls handles scrolling through choices when holding the key.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I was trying to get the initial pause after the first move of about a half second, then the fast scroll.

    I dont see a way to configure that using only a hold.
  • Hm, is your battle menu's GUI box using custom menu controls that only use the hold key? Otherwise I'll check it out, should work the same in all dialogues/menus that use the same input keys.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I don't seem to have any custom controls selected for any GUI boxes
  • Tested this and it's working fine on my end, although I'm using key codes instead of unity inputs.
    Anyway, next update will add a separate option for continued menu input to allow this behaviour without a complicated control setup :)
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • ok, I use the input manager to handle kb and gamepad controls the same, this didnt seem so complicated to me but i definitely cant get it to work in an atb battle menu.

    Works fine in my main menus.
  • DIscovered a bit more about what is going on here. It seems to be just one of my input definitions is not working, only in battle menus.

    image

    image

    For some reason this input definition just doesnt work in battle menus, though I cant seem to figure out why. It works fine in my main menu.
  • Found the issue you're having. It's basically the input manager input being smoothed by the sensitivity setting. You probably don't get this during other menus due to the game being paused and ORK using the raw axis in that case.

    I'll add an option to use the raw axis in the next update to fix this. Otherwise I'd recommend setting up Key Code input keys for keyboard input instead of using the input manager.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.