hello
im getting a weird error when im updating to 3.3.1 "value cannot be null (collections)" when I'm in battle and nothing is showing up
i can only work from 3.2.0 there it works everything as it should.

hmm..
Any suggest?
  • ArgumentNullException: Value cannot be null.
    Parameter name: collection
    System.ThrowHelper.ThrowArgumentNullException (System.ExceptionArgument argument) (at <695d1cc93cca45069c528c15c9fdd749>:0)
    System.Collections.Generic.List`1[T].InsertRange (System.Int32 index, System.Collections.Generic.IEnumerable`1[T] collection) (at <695d1cc93cca45069c528c15c9fdd749>:0)
    System.Collections.Generic.List`1[T].AddRange (System.Collections.Generic.IEnumerable`1[T] collection) (at <695d1cc93cca45069c528c15c9fdd749>:0)
    GamingIsLove.Makinom.Schematics.Nodes.CallHUDNode.Execute (GamingIsLove.Makinom.Schematics.Schematic schematic) (at :0)
    GamingIsLove.Makinom.Schematics.Schematic.ExecuteNextNode () (at :0)
    GamingIsLove.Makinom.Schematics.Schematic.Start () (at :0)
    GamingIsLove.Makinom.Schematics.Schematic.PlaySchematic (System.Object source, GamingIsLove.Makinom.Schematics.ISchematicStarter starter, System.Object machineObject, System.Object startingObject, System.Boolean isBlocking, GamingIsLove.Makinom.MachineUpdateType updateType, System.Int32 inputID) (at :0)
    GamingIsLove.Makinom.Schematics.Schematic.Play (GamingIsLove.Makinom.MakinomSchematicAsset asset, System.Object source, GamingIsLove.Makinom.Schematics.ISchematicStarter starter, System.Object machineObject, System.Object startingObject) (at :0)
    GamingIsLove.ORKFramework.Components.BattleComponent.StartBattle () (at <86fd4d59bede4b328bf03d5f82654fd8>:0)
    GamingIsLove.ORKFramework.Components.BattleComponent.StartInteraction (UnityEngine.GameObject startingObject) (at <86fd4d59bede4b328bf03d5f82654fd8>:0)
    GamingIsLove.ORKFramework.Components.BattleComponent.StartGroup (GamingIsLove.ORKFramework.Group g, GamingIsLove.Makinom.Schematics.ISchematicStarter starter) (at <86fd4d59bede4b328bf03d5f82654fd8>:0)
    GamingIsLove.ORKFramework.Components.CombatantComponent.Update () (at <86fd4d59bede4b328bf03d5f82654fd8>:0)
  • okay i solved the problem... i needed to restore a backup. No the error is gone and work works nicely
  • Im having the issue again...no i have return to 3.2.0

    I dont know what this error caused.
  • edited June 28
    I think this is caused by using the node with using Change Users and Clear.
    Will be fixed in the next update.

    Generally, how do you use this node?
    E.g. it's not needed for most of ORK's HUDs.
    Post edited by gamingislove on
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.