Hello !

I have a small problem but I can't identify if it comes from Unity or Ork.

Here is the problem: the sounds of the attacks during the fight (turn by turn) do not work on a scene of my game (but absolutely all the others are working: UI, music player) in particular and I do not remember having had any problem before on this part there.

Another astonishing fact that has been happening since today; following this problem I decide to restart my pc, telling myself that it may be a hardware problem and when I launch this scene after about ten seconds walking around in unity crash. If I restart Unity, I restart another scene before the one that poses the problem, there is no crash but on the other hand no more sound for the attacks.

I tried to deactivate a certain number of gameobjects in the scene in case but without success. I really do not understand what is happening and I would like to have an informed opinion on the question.
  • Probably due to audio listener being too far away or audio source setup. UI sounds and music are played as 2D sounds, i.e. without any positioning interfering with it.

    This is managed by the Spatial Blend setting of an audio source. If it's a 3D sound, the 3D sound settings come into play, e.g. min/max distance, rolloff, etc.

    Otherwise, check the Unity console if you get any messages - and the log file regarding crashes :)
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Well when I try to open the log file ,it crashes ans my pc freeze x)

    But I still managed to find the problem by activating my gameobjects one by one in the scene until it bug (it was long x) )
    In fact it was simply that I had a lava geyser field with a 3D sound on a short distance having the maximum priority and suddenly the effects in combat (when it triggered in this area) was not audible.
    I just have the lowest priority on the geysers and now it works ^^
Sign In or Register to comment.