In Unity 2022.3.8f1 (LTS), when I press the Play button to test, press the Play button again to stop, and then press the Play button again, the following error message appears and I cannot test ORK.
It seems that Canvas is not being opened properly.
The version of ORK is 3.15.2.

MissingReferenceException: The object of type 'Canvas' has been destroyed but you are still trying to access it.
Your script should either check if it is null or you should not destroy the object.
GamingIsLove.Makinom.UI.UnityUIHelper.CreateHUD (GamingIsLove.Makinom.HUDSetting settings, UnityEngine.GameObject prefab, GamingIsLove.Makinom.UILayerAsset layerAsset) (at <75be63ef657b4d40abf452d6950f5f85>:0)
GamingIsLove.Makinom.UI.UnityUIInformationHUDSettings.CreateHUD (GamingIsLove.Makinom.HUDSetting settings) (at <75be63ef657b4d40abf452d6950f5f85>:0)
GamingIsLove.Makinom.UI.InformationHUDSetting.CreateHUD (GamingIsLove.Makinom.HUDSetting settings) (at <bd910418d8d8436c8c34d66bbb2d0dbd>:0)
GamingIsLove.Makinom.UI.InformationHUDInstance.CreateHUD (System.Object user) (at <bd910418d8d8436c8c34d66bbb2d0dbd>:0)
GamingIsLove.Makinom.UI.InformationHUDInstance..ctor (GamingIsLove.Makinom.HUDSetting settings, GamingIsLove.Makinom.UI.InformationHUDSetting typeSettings) (at <bd910418d8d8436c8c34d66bbb2d0dbd>:0)
GamingIsLove.Makinom.UI.BaseUIInformationHUDSettings.CreateInstance (GamingIsLove.Makinom.HUDSetting settings, GamingIsLove.Makinom.UI.InformationHUDSetting typeSettings) (at <bd910418d8d8436c8c34d66bbb2d0dbd>:0)
GamingIsLove.Makinom.UI.InformationHUDSetting.CreateInstance (GamingIsLove.Makinom.HUDSetting settings) (at <bd910418d8d8436c8c34d66bbb2d0dbd>:0)
GamingIsLove.Makinom.HUDSetting.CreateInstance () (at <bd910418d8d8436c8c34d66bbb2d0dbd>:0)
GamingIsLove.Makinom.HUDSetting.get_Instance () (at <bd910418d8d8436c8c34d66bbb2d0dbd>:0)
GamingIsLove.Makinom.UI.BaseUIHandler.GetHUD (GamingIsLove.Makinom.HUDAsset asset) (at <bd910418d8d8436c8c34d66bbb2d0dbd>:0)
GamingIsLove.Makinom.HUDsSettings.Create () (at <bd910418d8d8436c8c34d66bbb2d0dbd>:0)
GamingIsLove.Makinom.UI.BaseUIHandler+<CreateHUDs>d__120.MoveNext () (at <bd910418d8d8436c8c34d66bbb2d0dbd>:0)
UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <10871f9e312b442cb78b9b97db88fdcb>:0)
  • I think this is related to a known issue where having the ORK/Makinom editor open during play mode changes and using domain reload in Unity causes issues. This'll be fixed in the next update.

    For now, this should be gone if you disable using domain reload in Unity, which also makes playing a lot faster :)
    Go to Edit > Project Settings... > Editor in the Unity menu and scroll down to the Enter Play Mode Settings.
    Enable Enter Play Mode Options and disable Reload Domain and Reload Scene.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on!
  • Thanks.
    I have improved the situation, but originally it was with DomainReload off.
    In that state, I had a problem with GlobalMachine's Auto Execution not working.
    So I turned EnterPlayModeOptions off, tried it, no change, restarted UnityEditor and it worked, but this error appeared.
    I turned on EnterPlayModeOption again, and when I tried it again, the error improved, and for some reason AutoExecution also started working.

    This was a puzzling behavior, so I am reporting it just in case.
  • edited September 20
    Good morning,

    Same on my side, I've encountered a lot of problems since I switched to Unity 2022 (it's perhaps a link with the latest Ork 3 updates)

    Initially (unity 2019 and previous version of ork 3 I don't remember which one) I had deactivated "Reload domain" and I could have the Makinom/window open, make modifications during "Runtime" save in Ork and everything was taken into account etc...

    Since then it's been an ordeal ^^ if I deactivate Reload domain, entry in runtime version (Play mode) is done very quickly but many Ork elements are not taken into account even when I save and close the editor (I wasted 2 hours trying to understand why my " HUD" did not appear. I re-enabled "Reload domain" and they magically started appearing. same certain changes that I make on Ork (when reload domain is disabled) they only took into account when I restart unity -_-. for the little anecdote (with Reload domain activated), in my "teleport" combat system the new scene was loaded but nothing was launched and I had the error message in the console "you are trying to use scene changer , but this one was destroyed etc..." I added a wait time before and after the scene change in the schematic, and that solved the problem but now it's when is going which also tells me Canvas was destroyed and that I can't access it....
    I therefore have to juggle between the different parameters ( reload domain on/off ) but it is quite complicated to always be sure that what we have done has been taken into account. I'm hesitant to know if it's me who did things wrong or if it's a bug linked to these problems. while waiting for a correction, thanks in advance
    Post edited by MadMaxx on
  • @MadMaxx
    Do you already use the latest ORK version (3.16.1) that came out this week?
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on!
  • Good morning,

    I think not, I am currently in:

    Unity 2022.3.7f1
    Ork 3.15.2

    I will update Ork and get back to you.

Sign In or Register to comment.