• @Acissathar
    Yeah, node groups are currently bugged when you select them, will be fixed in the next update.
    I'd recommend to not use them for now.

    @MMalone
    Might be due to the editor window being too small - I think it needs to have a width around 1500 to have enough space to show all.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited August 2
    Combatant Spawners with sphere colliders seem to only spawn around the outer edge of the sphere (and rarely, very near the center) instead of filling the space.

    example image:
    https://ibb.co/23TbB06
    Post edited by SpaceDoubt on
  • @SpaceDoubt
    Can't confirm that - maybe check your layer settings, e.g. the spawner blocking the raycast?
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • @gamingislove My bad, I had the sample distance (under 'spawn settings') set too low. And now I'm realizing it's using the collider's bounds which are a box anyway, so I guess there's no real reason to use a sphere collider with spawners.

    Thanks for checking it out!
  • @gamingislove

    We have just purchased this asset for a game development and where having issues with the settings window throwing an error already reported here:
    https://forum.orkframework.com/discussion/7041/ork-3-bug-reports/p2

    the fix is pretty easy since it is related with the editor gui drawing that had changed since 5.6+ more or less that causes and error like this one:
    GUI Window tried to begin rendering while something else had not finished rendering! Either you have a recursive OnGUI rendering, or the previous OnGUI did not clean up properly.

    which at the end prevented the dropdown buttons to work and show the popup window for searching options, the solution is to put all those PopupWindow.Show inside the EditorApplication.delayCall to avoid the problem and the dropdown buttons works as they should :)
  • @gamingislove Putting a manual "Wait" node in-between Fade Screen nodes seems to break fading completely? The schematic is set to block, and after the wait time the block is removed as expected but we never fade back in. Without the wait node though, we fade in as expected.

    Without a wait node:

    image

    image

    With a wait node:

    image

    image
  • @rhodnius
    Thanks for the tip, will check out delayCall for this.

    @Acissathar
    Not happening here - also, in case Add Quest results in Failed (e.g. quest already added) it'll not continue due to no connected node.
    Generally, depending on the game's state and the machine component's setup wait times can halt the schematic, e.g. game being paused and the machine not having In Pause enabled.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited August 5
    @gamingislove Added some console log nodes and it is successfully adding the quest, it just gets stuck on the wait node.

    However, if I place the wait node before the Add Quest node, everything works as expected with no other changes at all. Super odd, because when the wait node is after it acts as if the schematic has finished (allowing player input) which it is correctly blocking before that point.

    I can just use the wait node before hand and continue on, would it help to send an example project?

    Edit: For anyone in the future, the issue was caused by my Game Manager Object disabling the machine object as soon as the quest was added which stopped the schematic. Just need to no longer destroy on finish and it's good to go. Thanks GiL! :)
    Post edited by Acissathar on
  • The 'Has In Inventory Fork' Node doesn't seem to be working right. It's not failing when it should.
    I compared it with the non-Fork version and get different results.
  • @SpaceDoubt
    Can confirm this - will be fixed in the next update.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I have noticed a potential bug with the highlight HUD;

    When a selecting players HUD is set to Fade HUD Blink it will work until you use an ability that allows you to select yourself. If you cancel that selection, upon returning the selecting player HUD doesn't blink anymore.

    For example if my player HUD is blinking and I choose to cast heal which allows me to target a member of my player battle group, if I select the currently active player with the UI selection and then cancel and return to the ability selection menu it will not continue blinking that player.
  • edited August 11
    I think "Node Groups" might be broken in all schematic screens. If anyone else can confirm this, I'm getting a blank screen every time I attempt to use it. Using the latest Ork 3 version on Unity 2019 LTS.
    Nvm, it was already mentioned before, I should have read a bit before posting.
    Post edited by Dre788 on
  • If the Camera Control Target changes while the camera is currently rotating, the camera goes flying.

    You can test it by setting Battle Grid Settings > Move Command to Camera Control Target and using arrow keys to select where to Grid Move while rotating the camera with the mouse. Additional info: In Game Controls > ORK Control Settings, I'm using a (1s) Control Target Transition and have Rotation Damping set to 2. Rotation Setting Block On Target Change is selected.

    The problem is that the player using a controller can initiate rotation and then target change before the rotation has time to finish. Thanks for your help. Oh, by the way, your Top Down Border camera is really quite good—I started integrating Ootii's today, but ultimately decided I'd rather use ORK's camera after all.
  • @supportreport1
    HUD blink will be fixed in the next update.

    @Scyra
    There currently seems to be a general issue with fading rotation in camera transitions - should be fixed in the next update.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • @gamingislove Since the update, I'm seeing my quest HUD show up on the main menu (no changes other than updating) so I'm guessing it maybe has to do with the new HUD conditionals?

    Main menu:
    image

    HUD display:

    image
    image
Sign In or Register to comment.